TL-WR941ND v.3 - time sync problems

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
Tepl
DD-WRT Novice


Joined: 12 Feb 2019
Posts: 2

PostPosted: Tue Feb 12, 2019 14:19    Post subject: TL-WR941ND v.3 - time sync problems Reply with quote
Hey.
I have TL-WR941ND v.3 with DD-WRT v3.0-r36006 on board.
My problem is time sync using NTP servers. When I setup it to use local NTP server (based on Windows Server 2008 in same network with router) it working perfect. But it not working for remote NTP servers. For my experiments I put syslog on, stop process_monitor and force sync using ntpclient command. I get this result:
Code:
daemon.debug ntpclient[1863]: Connecting to pool.ntp.org [192.36.143.130]
daemon.debug ntpclient[1863]: Timed out waiting for pool.ntp.org [192.36.143.130]
daemon.debug ntpclient[1873]: Connecting to 192.36.143.130 [192.36.143.130]
daemon.debug ntpclient[1873]: Timed out waiting for 192.36.143.130 [192.36.143.130]
daemon.debug ntpclient[1881]: Connecting to 192.168.1.2 [192.168.1.2]
daemon.info ntpclient[1881]: Time set from 192.168.1.2 [192.168.1.2]

So... It look like is not problem with my DNS. It's more like something restricting Internet connection for ntpclient, but what and why?!

Maybe someone could help me to answer why it so?

For extra info: Router working as gateway and using PPPOE WAN connection. SPI Firewall is disabled. Ping for remote NTP servers when I put ntpclient command is normal. I already tried another remote NTP servers, result is the same ("Timed out waiting for..."). And I can't use newer firmware, because they bricked my router.

P.S.: Sorry for my English, it's not good enoght.
Sponsor
ddaniel51
DD-WRT Guru


Joined: 19 Feb 2013
Posts: 1290

PostPosted: Tue Feb 12, 2019 23:07    Post subject: Reply with quote
I use the NTP server on my ISP's network. Works well.
_________________
Segment 1 R9000 10Gb LAN, 1Gb ISP Kong & BS
Wired AP 1 R9000 10Gb LAN
Wired AP 2 R9000 10Gb LAN
Wired AP 3 R9000 1Gb LAN
Wired AP 4 R9000 1Gb LAN
Wired AP 5 R7800 1Gb LAN OpenWRT Kong
www.desipro.de/openwrt/ (Kong's)
YAMon usage-
www.monitoring.com/manualInstall.php
jxm
DD-WRT Guru


Joined: 23 Jul 2017
Posts: 705
Location: Brisbane, Australia

PostPosted: Thu Feb 14, 2019 2:13    Post subject: Reply with quote
Using pool.ntp.org is not recommended. See here
https://www.ntppool.org/zone/se

Cheers
Tepl
DD-WRT Novice


Joined: 12 Feb 2019
Posts: 2

PostPosted: Fri Feb 15, 2019 5:14    Post subject: Reply with quote
jxm, it was just an example.
Of course I tried to use many differents remote NTP servers, but result was the same.
See logs below:
Code:
daemon.debug ntpclient[3111]: Connecting to 0.pool.ntp.org [199.223.248.101]
daemon.debug ntpclient[3111]: Timed out waiting for 0.pool.ntp.org [199.223.248.101]
daemon.debug ntpclient[3114]: Connecting to 1.pool.ntp.org [192.36.143.130]
daemon.debug ntpclient[3114]: Timed out waiting for 1.pool.ntp.org [192.36.143.130]
daemon.debug ntpclient[3117]: Connecting to 2.pool.ntp.org [80.93.50.95]
daemon.debug ntpclient[3117]: Timed out waiting for 2.pool.ntp.org [80.93.50.95]
daemon.debug ntpclient[3144]: Connecting to 0.europe.pool.ntp.org [193.145.15.15]
daemon.debug ntpclient[3144]: Timed out waiting for 0.europe.pool.ntp.org [193.145.15.15]
daemon.debug ntpclient[3147]: Connecting to 1.europe.pool.ntp.org [213.251.52.202]
daemon.debug ntpclient[3147]: Timed out waiting for 1.europe.pool.ntp.org [213.251.52.202]
daemon.debug ntpclient[3150]: Connecting to 0.se.pool.ntp.org [83.168.200.198]
daemon.debug ntpclient[3150]: Timed out waiting for 0.se.pool.ntp.org [83.168.200.198]
daemon.debug ntpclient[3153]: Connecting to 1.se.pool.ntp.org [192.36.143.130]
daemon.debug ntpclient[3153]: Timed out waiting for 1.se.pool.ntp.org [192.36.143.130]
daemon.debug ntpclient[3164]: Connecting to 0.us.pool.ntp.org [206.55.191.142]
daemon.debug ntpclient[3164]: Timed out waiting for 0.us.pool.ntp.org [206.55.191.142]
daemon.debug ntpclient[3167]: Connecting to 1.us.pool.ntp.org [12.167.151.2]
daemon.debug ntpclient[3167]: Timed out waiting for 1.us.pool.ntp.org [12.167.151.2]
daemon.debug ntpclient[3170]: Connecting to 0.de.pool.ntp.org [90.187.19.113]
daemon.debug ntpclient[3170]: Timed out waiting for 0.de.pool.ntp.org [90.187.19.113]
daemon.debug ntpclient[3173]: Connecting to 1.de.pool.ntp.org [138.201.64.208]
daemon.debug ntpclient[3173]: Timed out waiting for 1.de.pool.ntp.org [138.201.64.208]
daemon.debug ntpclient[3184]: Connecting to 0.uk.pool.ntp.org [194.80.204.184]
daemon.debug ntpclient[3184]: Timed out waiting for 0.uk.pool.ntp.org [194.80.204.184]
daemon.debug ntpclient[3187]: Connecting to 1.uk.pool.ntp.org [109.74.195.175]
daemon.debug ntpclient[3187]: Timed out waiting for 1.uk.pool.ntp.org [109.74.195.175]
daemon.debug ntpclient[3190]: Connecting to time.google.com [216.239.35.0]
daemon.debug ntpclient[3190]: Timed out waiting for time.google.com [216.239.35.0]
daemon.debug ntpclient[3209]: Connecting to time2.google.com [216.239.35.4]
daemon.debug ntpclient[3209]: Timed out waiting for time2.google.com [216.239.35.4]
daemon.debug ntpclient[3224]: Connecting to time-a-g.nist.gov [129.6.15.28]
daemon.debug ntpclient[3224]: Timed out waiting for time-a-g.nist.gov [129.6.15.28]
daemon.debug ntpclient[3227]: Connecting to time-b-g.nist.gov [129.6.15.29]
daemon.debug ntpclient[3227]: Timed out waiting for time-b-g.nist.gov [129.6.15.29]
daemon.debug ntpclient[3230]: Connecting to time-a-b.nist.gov [132.163.96.1]
daemon.debug ntpclient[3230]: Timed out waiting for time-a-b.nist.gov [132.163.96.1]
daemon.debug ntpclient[3241]: Connecting to time-b-b.nist.gov [132.163.96.2]
daemon.debug ntpclient[3241]: Timed out waiting for time-b-b.nist.gov [132.163.96.2]
daemon.debug ntpclient[3244]: Connecting to 192.168.1.2 [192.168.1.2]
daemon.info ntpclient[3244]: Time set from 192.168.1.2 [192.168.1.2]

Actially I think time services (ntpclient and etc) can't see my PPPOE connection with ISP or can't use it. But I have no any idea why so...
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum