New Build: r37908 12-4-18

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
BobbyLee
DD-WRT User


Joined: 04 Jul 2016
Posts: 131

PostPosted: Wed Dec 05, 2018 1:46    Post subject: New Build: r37908 12-4-18 Reply with quote
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2018/12-04-2018-r37908/

Installed factory-to-ddwrt using IE from Linksys partition on WRT3200ACM and no reset, no issues. OpenVPN server working and wireless devices connected fine.

_________________
Linksys WRT3200ACM
Currently using Linksys Firmware until DDWRT lets my ObiTalk 202 complete calls when connected via WiFi
Last used DD-WRT Version: r38326
OpenVPN server


Last edited by BobbyLee on Thu Dec 06, 2018 8:58; edited 3 times in total
Sponsor
WENED
DD-WRT User


Joined: 30 May 2017
Posts: 249
Location: Rural Manitoba

PostPosted: Wed Dec 05, 2018 3:45    Post subject: WRT3200acm Reply with quote
Webflash WRT3200acm r37860 -> r37908 using IE11 no reset.

Same as with r37882 - No WAN connection even after reboot. Play with setup page and apply settings to restore WAN. If reboot done loss of WAN.

ESP8266 devices won't connect with wmm enabled.

Suddenly lost GUI interface.

Used putty to switch partitions and reverted back to r37860.

_________________
WRT3200acm Master 5GHz AP r40009
WRT3200acm Client-Bridge r40009
WRT1900Ac V1 Client-Bridge r40009
WRT1900AC V1 Client-Bridge r40009
WRT1900AC V1 Client-Bridge r40009
WRT1200AC V1 SPARE r40009
WRT54G DD-WRT v3.0-r37305 micro Client-Bridged for 1 IP Camera
EX6200 DD-WRT r38535 - Spare
EX7000 Stock Firmware Spare
Devices and Cameras and Sensors
12 WiFi cameras, 4 desktops, 1 laptop, 10 Sonoff Basic/TH16, Artisan 700 Printer, Ongoing testing of other devices.
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 96
Location: FL

PostPosted: Wed Dec 05, 2018 13:50    Post subject: Reply with quote
this firmware is working great so far for me
Client bridge, Vlans.
Wireless 2.4 and 5ghz both are fine
No apple device to test.

Firmware: DD-WRT v3.0-r37908 std (12/04/1Cool
Time: 08:49:51 up 8:22

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2019
SVN Timeline:
https://svn.dd-wrt.com/timeline
Issues:
1. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
ALTERNATE for VAP issue run command ifconfig ath0.1 down then ifconfig ath0.1 up ( works better for me )

Linksys WRT1900ACv1 07-20-2019-r40400
WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
deeproot
DD-WRT Novice


Joined: 17 Aug 2007
Posts: 18

PostPosted: Thu Dec 06, 2018 3:27    Post subject: Reply with quote
I have been having problems the last few builds.(2.4ghz and 5ghz not working/ crashing needing reboots) I saw someone else said they re-configured from the ground up and didnt use the backup.

I did this yesterday and the router is working great again for the first time in a few weeks.

wrt3200acm

_________________
dd-wrt user nonstop / low maintenance luker
WENED
DD-WRT User


Joined: 30 May 2017
Posts: 249
Location: Rural Manitoba

PostPosted: Thu Dec 06, 2018 20:41    Post subject: wrt3200 r37908 Reply with quote
Being the stubborn old fart I am I can't give up on a problem.

This time I swapped my two 3200's, reset to factory, installed Lynksys software, reset again to factory, then upgraded to 37908.

I re-entered all my settings from scratch with the exception of my 99 static list which I loaded using Telnet and my Port Forwards. I checked for Internet connection after each step by executing a reboot. All went well until I loaded my Port Forwards at which point my WAN would no longer connect.
I had to go through complete reset procedure again and re-enter all my settings to get back to full operation. This time I entered a couple of my Port Forwards manually and all went well.
Not sure if the 5Ghz problem is also corrected but after 16 hrs. everything is stable. I do hope that I don't have to note tomorrow about the 5Ghz dying, but I guess that will just give me another challenge to fix.

I was able to swap back the two 3200's using the config files created by my efforts without problem, so I can only assume that my port forward configuration was somehow corrupt as all seems good now.

_________________
WRT3200acm Master 5GHz AP r40009
WRT3200acm Client-Bridge r40009
WRT1900Ac V1 Client-Bridge r40009
WRT1900AC V1 Client-Bridge r40009
WRT1900AC V1 Client-Bridge r40009
WRT1200AC V1 SPARE r40009
WRT54G DD-WRT v3.0-r37305 micro Client-Bridged for 1 IP Camera
EX6200 DD-WRT r38535 - Spare
EX7000 Stock Firmware Spare
Devices and Cameras and Sensors
12 WiFi cameras, 4 desktops, 1 laptop, 10 Sonoff Basic/TH16, Artisan 700 Printer, Ongoing testing of other devices.
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 131
Location: South Carolina

PostPosted: Thu Dec 06, 2018 21:59    Post subject: DD-WRT v3.0-r37908 std (12/04/18) Reply with quote
WRT3200ACM V1 r37908 Firefox 63.0.3 (64-bit) webflash

OpenVPN CLIENT works fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
2.4GHz wpa2 CCMP-129 (AES)working fine 20MHz Mixed
NAS via USB Samba also working fine
NBA Jam
DD-WRT Novice


Joined: 25 Nov 2018
Posts: 26

PostPosted: Fri Dec 07, 2018 0:20    Post subject: Reply with quote
WRT1900AC v1

Result: 5GHz Channel "Unknown" initially. Checked Wifi security settings and saw that some options that were previously available are no longer available. Clicked "Apply" on 5GHz connection security settings, and the channel began broadcasting again.

Everything is up and stable.
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 97

PostPosted: Sat Dec 08, 2018 19:05    Post subject: Reply with quote
Smooth update, no issues. Both radios working
_________________
LinkSys WRT3200ACM
DD-WRT v3.0-r40134 std (06/27/19)
DNSMasq,Local DNS
CloudFlare DNS
ExpressVPN OpenVPN Client
Static Leases & DHCP
2.4 & 5GHz clients
Comcast 1Gbps/35Mbps
wildflower1975
DD-WRT Novice


Joined: 10 Sep 2012
Posts: 5

PostPosted: Sun Dec 09, 2018 3:09    Post subject: failing to update from v35681 Reply with quote
On the WRT1900ACSv2

I have v35681 on both partitions

I've tried installing about 3 times:
11-27-2018-r37860 and
12-04-2018-r37908
using the firmware upgrade method inside the Admin page on the DD-WRT GUI.

After about 10-20 minutes of Chrome saying
"Upgrading firmware...
Please, wait"

Opening a new tab or window in the browser, the GUI isn't responding and I give up.

I've seen an "upgrade failed" message - but can't remember how or when.

the ssh connection is responsive throughout and the router maintains internet connections/traffic for other browser tabs/clients.

is there an upgrade log or something to track where it's up to?

I haven't tried flashing back to Linksys yet
BobbyLee
DD-WRT User


Joined: 04 Jul 2016
Posts: 131

PostPosted: Sun Dec 09, 2018 3:42    Post subject: Re: failing to update from v35681 Reply with quote
wildflower1975 wrote:
After about 10-20 minutes of Chrome saying
"Upgrading firmware...
Please, wait"

Just wondering, have you tried the install with IE? Chrome and FireFox seems to give some folks problems. I quit using Chrome for installs because it gave me problems and now I always use IE.

_________________
Linksys WRT3200ACM
Currently using Linksys Firmware until DDWRT lets my ObiTalk 202 complete calls when connected via WiFi
Last used DD-WRT Version: r38326
OpenVPN server
wildflower1975
DD-WRT Novice


Joined: 10 Sep 2012
Posts: 5

PostPosted: Sun Dec 09, 2018 5:56    Post subject: using IE Edge works Reply with quote
that's curious
Chrome 71.0.3578.80 on Ubuntu doesn't work
but Edge 17.17134 on Win 10 does

I assume there's something different in the Javascript engines?

I'm not sure how the GUI is written, (compliant html5 or something else?)

I can't complain (as it's free), but I could help with the HTML5 part, (I know LAMP development).

I haven't looked for the GUI code on the repo

_________________
WRT1900ACSv2 v35681 2018-04-06
shmerl
DD-WRT User


Joined: 08 Dec 2014
Posts: 72

PostPosted: Sun Dec 09, 2018 9:16    Post subject: Reply with quote
Upgraded my Linksys WRT1900ACS to this build without resetting. Both WiFi access points stopped broadcasting first, but they did appear after I tweaked some settings back and forth.
Kuketon
DD-WRT Novice


Joined: 02 Sep 2018
Posts: 2

PostPosted: Sun Dec 09, 2018 12:25    Post subject: Re: failing to update from v35681 Reply with quote
wildflower1975 wrote:
On the WRT1900ACSv2

I have v35681 on both partitions

I've tried installing about 3 times:
11-27-2018-r37860 and
12-04-2018-r37908
using the firmware upgrade method inside the Admin page on the DD-WRT GUI.

After about 10-20 minutes of Chrome saying
"Upgrading firmware...
Please, wait"

Opening a new tab or window in the browser, the GUI isn't responding and I give up.

I've seen an "upgrade failed" message - but can't remember how or when.

the ssh connection is responsive throughout and the router maintains internet connections/traffic for other browser tabs/clients.

is there an upgrade log or something to track where it's up to?

I haven't tried flashing back to Linksys yet


I had the same issue with chrome, worked well for me using firefox.
Kuketon
DD-WRT Novice


Joined: 02 Sep 2018
Posts: 2

PostPosted: Sun Dec 09, 2018 12:32    Post subject: Works well on LinkSys WRT1900ACSv2 Reply with quote
No issues,

using:
OpenVPN server
5Ghz wifi

Addblocking via DNS works, didnt work for me with version r37882.
SurprisedItWorks
DD-WRT User


Joined: 04 Aug 2018
Posts: 216
Location: Appalachian mountains, USA

PostPosted: Sun Dec 09, 2018 15:12    Post subject: Re: Works well on LinkSys WRT1900ACSv2 Reply with quote
Kuketon wrote:
Addblocking via DNS works, didnt work for me with version r37882.


You mean Privoxy under Services>Adblocking? Or the AdGuard menu selection under "Encrypt DNS" in Services>Services>DNSMasq? Or you entered the IP of an ad-blocking DNS server under Static DNS in the Setup>BasicSetup page? What is it that now works that did not work before?

_________________
Five of the Linksys WRT1900ACSv2, on r39144 and r38159. On various: VLANs, client-mode travel router, two DNSCrypt DNS servers (incl Quad9), multiple VAPs, USB/NAS, OpenVPN client (random NordVPN server).

VLANs on the WRT1900ACSv2 and other two-CPU Linksys/Marvell routers:
https://www.dd-wrt.com/phpBB2/viewtopic.php?p=1091367

DNSCrypt for Quad9 DNS and/or multiple servers and/or missing DNSCrypt enable button: Sun Jan 06, 2019 post at
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318094
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum