Sudden Loss of Bandwidth on DLink DIR-890

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
DBB
DD-WRT Novice


Joined: 10 Dec 2016
Posts: 34

PostPosted: Sat Nov 17, 2018 18:45    Post subject: Sudden Loss of Bandwidth on DLink DIR-890 Reply with quote
My DLink DIR-890 router has been running flawlessly after having updated to the latest firmware 5 months ago. It is sitting behind AT&T’s Pace 5268AC serving up their 1GB fiber service. I routinely got 800-900MB down on a hardwired PC downstream from the DIR-890, until a few days ago. Now, I’m barely getting 40mb down. This speed was also verified from the ATT gateway’s built-in speed test, so I suspected the issue was with the ATT equipment.

ATT said they showed errors on the line and sent out a tech, who replaced the fiber ONT, which restored their gateway speedtest to correct levels. The tech tested out and verified proper speeds immediately inside on their gateway ports, so it would appear their stuff is good. Yet speeds from the dd-wrt built in test still shows 40mb, and verified from a hard wired PC.

What could have gone belly up? DIR-890 firmware is DD-WRT v3.0-r36168 std (06/20/1Cool.

Not looking forward to ripping out my wiring closet to troubleshoot, but is there somewhere in the configurations that I could review first?
Sponsor
DBB
DD-WRT Novice


Joined: 10 Dec 2016
Posts: 34

PostPosted: Tue Nov 20, 2018 7:37    Post subject: Reply with quote
Thanks for the reply, jxm.

I’ve checked the VLAN tab, and both WAN and computer ports are green.

I bit the bullet and reflashed back to DLink stock firmware and reinstalled dd-wrt up to the very latest build for my router (11/17j.

There seems to be no change to the speedtest results: about 50mb down. I’ve tried different physical ports, as well as cabling. I’m still getting 900mb down at the AT&T gateway.

I’m baffled - how likely is it that my router has gone south?
DBB
DD-WRT Novice


Joined: 10 Dec 2016
Posts: 34

PostPosted: Wed Nov 21, 2018 1:09    Post subject: Reply with quote
Well, it’s not the hardware... it looks more like an issue with dd-wrt - speedtest with the DLink factory firmware gets me over 900mb/down.

Testing again immediately after installing factory-to-ddwrt.bin and I get around 40mb/ down (erased nvram via telnet, too, so there shouldn’t be any old settings lingering around).

I’m baffled. What would cause a working, speedy dd-wrt install to suddenly stop down bandwidth so drastically?
DBB
DD-WRT Novice


Joined: 10 Dec 2016
Posts: 34

PostPosted: Wed Nov 21, 2018 3:31    Post subject: Reply with quote
Everything I’m testing is hardwired - no Wi-Fi involved.

So, can I go from a current beta version (is it brainslayer that’s downloaded here?) right into a Kong firmware? I looked into Kong’s some time ago before SFE was available, but loading it wasn’t overly apparent.

But my question stays the same: what would cause a solid, working dd-wrt install suddenly go into the tank? Since I haven’t messed with configurations for some time other than an occasional reboot, it seems like there would have to be some external interaction causing this. I do use a ddns service, and use OpenVPN to allow remote access into my network, and have a few ports forwarded. Grasping at straws, here.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 5914
Location: Netherlands

PostPosted: Wed Nov 21, 2018 8:57    Post subject: Reply with quote
Be sure to erase nvram after upgrading by telnetting into your router and do:
Code:
erase nvram && reboot

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
DBB
DD-WRT Novice


Joined: 10 Dec 2016
Posts: 34

PostPosted: Wed Nov 21, 2018 13:46    Post subject: Reply with quote
I erased nvram after loading dd-wrt, then restored from a backup (taken when the router was working at full speed).

Knowing that factory firmware works, I hate to go to the expense of replacing the router only to end up with the same results, but may need to try. To have something that was working suddenly degrade like this still makes me think there’s a hardware issue.

The only other things in the setup that I can think of would be:
- erasing nvram isn’t fully doing its job.
- an auto firmware update to the AT&T modem that has something obscure that dd-wrt doesn’t like.

I use the Velop mesh network gear for Wi-Fi and so have that portion of my router turned off. Is there a good gigabit router suitable for dd-wrt that does not have Wi-Fi capability?
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 5914
Location: Netherlands

PostPosted: Wed Nov 21, 2018 13:53    Post subject: Reply with quote
It is of no use restoring from backup if you have erased nvram, you should put your settings in manually!
_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
DBB
DD-WRT Novice


Joined: 10 Dec 2016
Posts: 34

PostPosted: Thu Nov 22, 2018 0:00    Post subject: Reply with quote
Didn't really matter in this case, egc. Further up, I mentioned that speedtest reflected the same poor speeds right after applying the factory-to-ddwrt.bin file from DLink stock, even before applying any settings or restores.

Dunno... Something has just gone belly-up for no apparent reason, after at least 5 months of solid performance. Doesn't make sense, and I'm at a loss on what else to try at this point.
DBB
DD-WRT Novice


Joined: 10 Dec 2016
Posts: 34

PostPosted: Sat Nov 24, 2018 4:16    Post subject: Reply with quote
I may have touched on the issue earlier - I stumbled on a rash of recent posts online that exactly mimics my situation. It appears that sometime in October, AT&T issued a firmware update to their 5268ac that has messed with DMZ Plus mode, effectively capping folk’s bandwidth to around 50mb. After having operated fine for a period of time, people started experiencing this issue with no change to their setup.

True to form, AT&T is not addressing the issue, and their tech support is blaming it on everyone’s router.

In DMZ Plus mode, I used to give my router/internal network a different IP scheme than that of the gateway’s default IP. So, not being a firewall guy, if I remove my router from DMZ Plus, how could I create a hole in the AT&T gateway for all ports and services without getting into a double NAT situation?

I think they have other hardware that uses IP pass through instead of DMZ Plus. Would that be a better option if I could get them to swap It out?
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum