New Brainslayer Build 10-10-18 - R37305

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page Previous  1, 2
Author Message
AmesJainchill
DD-WRT Novice


Joined: 10 Aug 2017
Posts: 37
Location: MI, USA

PostPosted: Thu Oct 11, 2018 20:17    Post subject: Reply with quote
BobbyLee wrote:

One issue, on the previous release r37139 Free and Used memory on the Status page was running about 50% for each and on this release r37305 it's running 81% Used and slowly increasing (and 19% Free). Is this going to cause any issues? It's the most Used memory I've seen on any DDWRT release since I started using it.


I see the same behavior in my version from 12/17. I don't think it's new specifically to this version. Memory jumps all over the place when copying files to the NAS whether I'm using win explorer, AndSMB on android or whatever, and it is mounted to jffs (files.db is about 30MB on the HDD currently).

Streaming media via miniDLNA pulls memory down to the 20% free range and doesn't really release it (seen as low as 16%). Copying files can release some of it as I've seen it go back up to 50% or so, but if you use miniDLNA it drains back down.

Unless there's something I missed on the config, it feels like poor memory mgt or some kind of leak, but it doesn't seem to impact performance of the router in any way for me, and I typically reboot every 7-10 days or so, if for no other reason than to pick up a different vpn ip and release "used" memory.

--- /dev/sda1
Block device, size 1.819 TiB (2000396321280 bytes)
Ext4 file system
Volume name "Seagte2TBII"
UUID 39B2AB12-C7C4-C24F-B468-6D599BF6146B (DCE, v12)
Last mounted at "/jffs"
Volume size 1.819 TiB (2000396320768 bytes, 488378008 blocks of 4 KiB)
/dev/sda1 mounted to /jffs

_________________
WRT3200ACM 1st Gen
DD-WRT v3.0-r33986 (12/04/17) std - SVN rev: 33986
Motorola MB8600
Comcast 600/20
ExpressVPN OpenVPN Client Manual Config
NAS and miniDLNA: 4TB Seagate USB3
Sponsor
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 335

PostPosted: Thu Oct 11, 2018 20:25    Post subject: Reply with quote
Definitely uses memory when actually accessing the drive. It has never caused me any issues. Memory recovers for me after use. I reboot router on a daily basis as I have no reason not to. The memory usage has never caused me an issue and I return to 300 to 400MB free after use of any NAS services (May take time). The Router USB NAS I use now just for MP3 and Movie files (And temp storage)...For backup I now use an OpenMediaVault server I built out of an old Core2 PC and just turn that on for imaging backups across my network (gigabit)...Much faster than my old way of backing up to a USB drive locally as all my computers are USB2.0.

AmesJainchill wrote:
BobbyLee wrote:

One issue, on the previous release r37139 Free and Used memory on the Status page was running about 50% for each and on this release r37305 it's running 81% Used and slowly increasing (and 19% Free). Is this going to cause any issues? It's the most Used memory I've seen on any DDWRT release since I started using it.


I see the same behavior in my version from 12/17. I don't think it's new specifically to this version. Memory jumps all over the place when copying files to the NAS whether I'm using win explorer, AndSMB on android or whatever, and it is mounted to jffs (files.db is about 30MB on the HDD currently).

Streaming media via miniDLNA pulls memory down to the 20% free range and doesn't really release it (seen as low as 16%). Copying files can release some of it as I've seen it go back up to 50% or so, but if you use miniDLNA it drains back down.

Unless there's something I missed on the config, it feels like poor memory mgt or some kind of leak, but it doesn't seem to impact performance of the router in any way for me, and I typically reboot every 7-10 days or so, if for no other reason than to pick up a different vpn ip and release "used" memory.

--- /dev/sda1
Block device, size 1.819 TiB (2000396321280 bytes)
Ext4 file system
Volume name "Seagte2TBII"
UUID 39B2AB12-C7C4-C24F-B468-6D599BF6146B (DCE, v12)
Last mounted at "/jffs"
Volume size 1.819 TiB (2000396320768 bytes, 488378008 blocks of 4 KiB)
/dev/sda1 mounted to /jffs

_________________
WRT1900ACSv2
BobbyLee
DD-WRT User


Joined: 04 Jul 2016
Posts: 131

PostPosted: Thu Oct 11, 2018 21:46    Post subject: Reply with quote
AmesJainchill wrote:
Unless there's something I missed on the config, it feels like poor memory mgt or some kind of leak, but it doesn't seem to impact performance of the router in any way for me, and I typically reboot every 7-10 days or so, if for no other reason than to pick up a different vpn ip and release "used" memory.

OK, forget the memory issue. You have this working so you can add and delete files to your storage with Windows Explorer? That's what I really want to be able to do. I PM'ed you.

_________________
Linksys WRT3200ACM
Currently using Linksys Firmware until DDWRT lets my ObiTalk 202 complete calls when connected via WiFi
Last used DD-WRT Version: r38326
OpenVPN server
AmesJainchill
DD-WRT Novice


Joined: 10 Aug 2017
Posts: 37
Location: MI, USA

PostPosted: Fri Oct 12, 2018 0:04    Post subject: Reply with quote
BobbyLee wrote:
OK, forget the memory issue. You have this working so you can add and delete files to your storage with Windows Explorer? That's what I really want to be able to do. I PM'ed you.


Replied. Looks like I could only attach 1 pic per pm, so you should have a few coming your way. Good luck!

_________________
WRT3200ACM 1st Gen
DD-WRT v3.0-r33986 (12/04/17) std - SVN rev: 33986
Motorola MB8600
Comcast 600/20
ExpressVPN OpenVPN Client Manual Config
NAS and miniDLNA: 4TB Seagate USB3
BobbyLee
DD-WRT User


Joined: 04 Jul 2016
Posts: 131

PostPosted: Fri Oct 12, 2018 23:38    Post subject: Reply with quote
AmesJainchill wrote:
Good luck!


Getting closer. Formatted to EXT4 and everything looks as it should, much better. Guess NTFS is giving these new releases problems, who knows. BUT it still won't let me save files or delete files off the USB Drive using Windows explorer. Read/Write is selected so I'm not sure why I can't copy or delete from drive. PM'ed you again.

Anyone know what version SMB the WRT3200ACM DD-WRT Firmware uses? Is it SMBv1? TIA

_________________
Linksys WRT3200ACM
Currently using Linksys Firmware until DDWRT lets my ObiTalk 202 complete calls when connected via WiFi
Last used DD-WRT Version: r38326
OpenVPN server


Last edited by BobbyLee on Sat Oct 13, 2018 3:25; edited 2 times in total
Skoda Zek
DD-WRT User


Joined: 07 Apr 2018
Posts: 73
Location: Calgary, AB Canada

PostPosted: Sat Oct 13, 2018 0:01    Post subject: Reply with quote
Any WRT32X users flash this build?

I am still running 37012 with no real complaints or concerns. Just curious if there are any issues or improvements for the WRT32X with this build. If not I'll just stick with 37012 until a later build with significant changes comes along.

Thanks

_________________
FIRMWARE: DD-WRT v3.0-r41328 std [10/15/19]
ROUTER: Linksys WRT32X
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 300

PostPosted: Sat Oct 13, 2018 14:26    Post subject: Reply with quote
Flashed my WRT1900ACv2 successfully. No issues and working well
spuriousoffspring
DD-WRT Guru


Joined: 05 Apr 2017
Posts: 982
Location: South of Heaven, USA

PostPosted: Sat Oct 13, 2018 20:15    Post subject: Reply with quote
For those of you who are experiencing issues with memory and are not already familiar with Linux, here are some Telnet/SSH diagnostic commands that may help:

free
Displays basic stats on memory

cat /proc/meminfo
Displays more detailed information on memory

top
Displays info on processes, cpu, memory, etc..
*Refreshes automatically

https://www.binarytides.com/linux-command-check-memory-usage/

_________________
DD-WRT Installation & Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117

WRT32X DD-WRT Installation Procedure
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569

IPVanish OpenVPN Client Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=308565

FIRMWARE: OpenWrt SNAPSHOT r8217-2cc821e / LuCI Master (git-18.276.41146-280dd33)
MODEM: ARRIS SURFBoard SB8200
ROUTER: Linksys WRT32X
USB NAS: Western Digital BLACK 1 TB Hardrive + Startech USB 3.0 External SATA III Enclosure
bytebandit01
DD-WRT User


Joined: 19 Sep 2017
Posts: 85

PostPosted: Sun Oct 14, 2018 17:32    Post subject: Reply with quote
can't update to this build from stock linksys fw Sad

after it uploads and reboot it somehow bricks my wrt1200ac, a reset at the back restores it back to default settings with stock fw still Sad

_________________
Router: Linksys WRT1200AC v2
Firmware: DD-WRT v3.0-r41075 std [09/20/19]
canmanxl
DD-WRT User


Joined: 02 Feb 2017
Posts: 51

PostPosted: Sun Oct 14, 2018 20:56    Post subject: Speed Reply with quote
This build has to be one of the better ones I have seen in a while. It is fast and works well.

Keep up the great work BS!!!
braco552
DD-WRT Novice


Joined: 15 Oct 2018
Posts: 10

PostPosted: Mon Oct 15, 2018 16:38    Post subject: Reply with quote
Upgraded my WRT1900ACS V2 from 36247 to 37305. I don't broadcast my SSID. All Windows clients connect no problem. But iPad and MacBook Pro won't. Once I enabled broadcast SSID, all clients connect. But that is not my preferred way. Want to keep my SSID hidden. So reverted back to 36247.
johnnyNobody999
DD-WRT User


Joined: 10 Jan 2014
Posts: 345

PostPosted: Tue Oct 16, 2018 2:34    Post subject: WRT3200ACM r37305 Reply with quote
sftp still doesn't work
zakaron
DD-WRT User


Joined: 03 Jun 2016
Posts: 90

PostPosted: Tue Oct 16, 2018 12:23    Post subject: Reply with quote
The good:
1. I am finally able to turn the 5Ghz radio back on with single user beamforming - before the channel would show up as "unknown" making it unusable. I had signal issues with beamforming off, so I just turned that radio off.

2. The driver version is 10.3.8.0-20180906, so I attribute that to fixing the above issue.


The not so good:
1. Upgrade file would not transfer using Chrome & hung the httpd process. Had to kill and restart httpd, but was fine with IE (normally use Firefox, but that has been glitching for me recently, so this may already be a known thing).

2. JFFS would not mount through the GUI. Tried several iterations of enabling/disabling/rebooting. I finally got it to mount via CLI. Luckily someone documented the commands which worked first try.

3. Noticed the same issue as Braco with Apple clients not connecting to a hidden SSID. Once unhidden, they connected fine. Unfortunately this is also a deal breaker for me, so I reverted back for now.
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum