D-Link DIR-882 A1 AC2600

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Ralink SoC based Hardware
Goto page Previous  1, 2, 3
Author Message
casualtester
DD-WRT User


Joined: 13 Dec 2015
Posts: 136

PostPosted: Fri Feb 09, 2018 22:20    Post subject: Reply with quote
Note: Firmware 02-08-2018-r34876 does not display correct time in the DIR-878. Whether NTP is selected (+15 hrs off) or not (+7 hrs off?), time is incorrect.
The DIR-882 may end up with the same problem.
Sponsor
ManHammer
DD-WRT Novice


Joined: 02 Feb 2018
Posts: 3

PostPosted: Sat Feb 10, 2018 21:03    Post subject: Reply with quote
The router works fine for me when it comes to wifi 5 and 2.4 works great. No disconnects nothing. But i want to use it as my main router to dial up. PPPoE is not working in the logs is see only this:
Jan 1 00:02:13 DD-WRT user.info : pppd : PPP daemon hanging, send SIGKILL
Jan 1 00:02:13 DD-WRT user.info : pppd : PPP daemon successfully stopped
Jan 1 00:02:13 DD-WRT daemon.notice pppd[2085]: pppd 2.4.7 started by root, uid 0
I tried to do this in all possible PPPoE settings with my cable connected and not. But still pppd is not working. I don't know how to get more informations out. Is there any logging possible on pppd. I even tried to start it via telnet but same issue there.
moll47u
DD-WRT Novice


Joined: 28 Dec 2010
Posts: 19
Location: Poland

PostPosted: Mon Feb 19, 2018 13:29    Post subject: Reply with quote
Hello, is possibile to connect at vht160 with this router witch dd-wrt?
I have Intel 9260 card in my laptop and I want connect at 1,7gbit ...
Gazooo
DD-WRT Novice


Joined: 31 Mar 2015
Posts: 23

PostPosted: Tue Feb 20, 2018 13:26    Post subject: PPPoE was broken Reply with quote
ManHammer wrote:
I don't know how to get more informations out. Is there any logging possible on pppd. I even tried to start it via telnet but same issue there.


PPPoE was broken for for a while. I think it's fixed in the latest version (but there were other issues). For my Dlink DIR-878 A1 the most stable build has been DD-WRT v3.0-r33607 std (10/25/17). No PPPoE disconnects.
sup2k
DD-WRT Novice


Joined: 26 Oct 2017
Posts: 6

PostPosted: Sun Apr 22, 2018 9:14    Post subject: Reply with quote
My DIR-882 connection keeps dropping. Turns out it's not just wifi but also ethernet.
Malachi
DD-WRT Guru


Joined: 17 Jul 2012
Posts: 6641
Location: Columbus, Ohio

PostPosted: Tue Jun 12, 2018 20:28    Post subject: Reply with quote
My dir-882 flashed with the latest, won’t enter into recovery mode. Is there any other way to restore factory firmware?
Is it a bug on recent builds?

_________________
I am far from a guru, I'm barely a novice.
Friko
DD-WRT Novice


Joined: 14 Dec 2014
Posts: 13

PostPosted: Sat Jun 23, 2018 0:45    Post subject: Reply with quote
What version is everyone using?
kbalint
DD-WRT Novice


Joined: 17 Jul 2018
Posts: 2

PostPosted: Tue Jul 17, 2018 17:51    Post subject: Reply with quote
I've installed the latest build to date, but PPPoe does not connect at all. does anyone have any info about that? how can I connect via ssh?
kbalint
DD-WRT Novice


Joined: 17 Jul 2018
Posts: 2

PostPosted: Mon Jul 23, 2018 9:59    Post subject: Reply with quote
I finally managed to make pppoe it work with the latest build to date.

I now have a serious problem with the wifi. I would like to use 2.4/5Ghz as well. From time-to-time 2.4's SID goes offline, sometimes clients get disconnected (happens every hour or so). 5ghz is even worse, clients get disconnected after max 2 minutes.

The max distance between the router and the clients is 4 meters, 90% time they physically can see the antennes, no obstruction.

Does anyone have a working config?
larkey
DD-WRT Novice


Joined: 26 Jul 2018
Posts: 1

PostPosted: Thu Jul 26, 2018 14:50    Post subject: Reply with quote
EDIT (Solved):

I got help from a very kind admin at the DLink-Forums who suggested downgrading the FW v1.00b7 (from here tsd.dlink.com.tw).

This isn't that easy because v1.10b2 won't downgrade, and the recovery is buggy, as described. However I found a workaround:

1. Enter recovery mode
2. Load the WebUI, browse the file upgrade file, do *not* hit "Upload"
3. Reboot the router, again into recovery mode (s.t. the upload will be the first request sent, thus succeeding).
4. Perhaps wait a little more than the 3:40mins until "Succeeded" is automatically printed, the router should automatically reboot.

This method should, in theory, also work for directly flashing factory-to-ddwrt.bin, but for me it didn't work, for some reason I did get the "Suceeded" message but not the DD-WRT webui. And every try thereafter with factory-to-ddwrt.bin resulted in "Firmware upgrade failed".

Anyway, after you flashed that file, flash the webflash.bin and you should be good to go!

----------------

Hello,

I'm having problems flashing any build to my device, which however is the EU (Germany) edition. But it seems to be identical hardware-wise from what I can gather (it even ships a power adapter for other countries). When I unpacked the Router it ran v1.01 and I did the transitional upgrade to v1.04 and then v1.10 from ftp://ftp.dlink.de/dir/dir-882/driver_software/ and then flash the firmware through the recovery mode, using FF and/or Chrome on Linux.

I booted into recovery mode by holding reset and shutting the router down and then up again, til the status LED was blinking. I had my laptop connected to one of the LAN ports on the router and assigned 192.168.0.2 ($ sudo ip address add 192.168.0.2/24 broadcast + dev enp4s0) and I successfully reached the recovery page. I tried all of these factory-to-ddwrt.bin files: 2017/r330066 (mentioned here), 2018/r36247 (listed on the downloads page), 2018/r36330 (also listed).

Every flash on every firmware version failed the same way: After I hit the "Upload" button (and the POST request got sent), the browser did not receive any answer immediately, as if the webserver instantly died / crashed. I waited for up to 15mins before I rebooted, just to be safe, but I was greeted with the stock D-Link firmware every time.

Does any of you have any idea what could be wrong, or any pointers how to access some log to debug the issue further?
deslatha
DD-WRT User


Joined: 12 Jul 2016
Posts: 78

PostPosted: Sat Aug 11, 2018 12:04    Post subject: Reply with quote
Anyone have uboot,please share. i need recovery.
m_p11
DD-WRT Novice


Joined: 09 Aug 2018
Posts: 1

PostPosted: Sat Aug 18, 2018 5:28    Post subject: Reply with quote
hello!
I have dir-882 with Russian firmware 3.5.0 by default.
and i cant install in recovery ANY other firmware's, always there is message that image failed to pass verification
Goto page Previous  1, 2, 3 Display posts from previous:    Page 3 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Ralink SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum