Linksys EA6900 - USB 3.0 flash drive not recognized/mounting

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
zhelev81
DD-WRT User


Joined: 04 Feb 2014
Posts: 53

PostPosted: Fri Mar 30, 2018 11:37    Post subject: Linksys EA6900 - USB 3.0 flash drive not recognized/mounting Reply with quote
Linksys EA6900 - USB 3.0 flash drive not recognized

Version : Firmware: DD-WRT v3.0-r35531 std (03/26/18 )

I have attached usb 3.0 stick 64 gb sandisk to the router but it is not mounting it.

File system is ext2

on usb 2.0 works fine

my setup is :





is this a known issue or ?

any help would appreciated ....
Sponsor
CEGN
DD-WRT Novice


Joined: 05 Nov 2010
Posts: 47
Location: Mx

PostPosted: Sat Mar 31, 2018 1:46    Post subject: Reply with quote
Hi.

I remember i read about lose the usb3.0 when switch to DD (probably in the install guide from egc) but i didn´t test it (i will now just to check).

But i did tested on usb2.0, trying to mount a 16gb stick with /opt and /jffs partitions. On this case the router wasn't able to mount on any way, and the solution was to change the partitions to ext4, after that the router mount them automaticaly, i don´t know why ext2 and ext3 didn't worked. Probably you can try with this solution

Edit-(testing) Well, the usb3.0 port doesn't recognize anything, but the usb2.0 port mount an usb3.0 Hard drive (500gb) NTFS
zhelev81
DD-WRT User


Joined: 04 Feb 2014
Posts: 53

PostPosted: Sat Mar 31, 2018 4:44    Post subject: Reply with quote
Yes this is what i have noticed. So is there any fix that we can apply for the usb 3 to work ?
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 5140
Location: Netherlands

PostPosted: Sat Mar 31, 2018 10:55    Post subject: Reply with quote
@jwh7 has done some work on the USB 3.0 port see page 9 of the EA6900 thread: https://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230&postdays=0&postorder=asc&start=120
As he is always very helpfull I think he doesn't mind if you PM (personal mail) him

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2491
Location: Indy

PostPosted: Sat Mar 31, 2018 14:34    Post subject: Reply with quote
egc wrote:
@jwh7 has done some work on the USB 3.0 port see page 9 of the EA6900 thread
I haven't actually done anything beyond those posts (since I have a USB3 share via an Almond+); also note I'm running Xwrt. I've been meaning to search how to manually set up samba though, since the Xwrt GUI stuff doesn't work to share it when the xhci USB3 driver is inserted. Does the GUI share work with xhci in DD?
_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
x64 OPNsense 20.1.2|FT2020.2: EA6900v1.1@1GHz, F7D8302@532|DD r42681: DIR-810L, WNDR4500v2 & 4000@533,
R6300v1, RT-N66U@663, E1500@353, WRT54G{Lv1.1,Sv6}@250
|OpenWRT 19.7.2: RT-ACRH13, R6220, WNDR3700v4
zhelev81
DD-WRT User


Joined: 04 Feb 2014
Posts: 53

PostPosted: Sat Mar 31, 2018 15:45    Post subject: Reply with quote
I did not understand anything of this really ,, I don't know what all those mean (Almond+, xwrt,)... how it is possible to make some tests in dd-wrt to see where the problem is coming from ?

all it works now in the latest dd-wrt is usb 2 with HDD but the spead is like 10 mb and i am not happy ,, this is why i wanted to use usb3 but it doesnt even mount... so that is my problem.
zhelev81
DD-WRT User


Joined: 04 Feb 2014
Posts: 53

PostPosted: Wed Apr 04, 2018 4:44    Post subject: Reply with quote
Anybody with any fix ?
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2491
Location: Indy

PostPosted: Wed Apr 04, 2018 14:22    Post subject: Reply with quote
zhelev81 wrote:
I did not understand anything of this really
Nothing a search can't provide. Xwrt (for a few non-Asus routers) is a fork of Merlin-AsusWRT (for Asus routers) which is a fork of Asus' (OEM) AsusWRT firmware for their routers. Xwrt has a build for EA6900, and the dev (XVortex) is the one also providing the 'fixed' CFE file.

After flashing Xwrt, the USB3 port also doesn't work, until I insert the module (driver) for it (xhci), as noted in my previous posts. I do not know if this works in DD-WRT.

The Almond+ is a Securifi touchscreen AC1750+smarthome device, which I use as an AP with USB3 share; this is why I haven't further pursued USB3 on the EA6900.

_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
x64 OPNsense 20.1.2|FT2020.2: EA6900v1.1@1GHz, F7D8302@532|DD r42681: DIR-810L, WNDR4500v2 & 4000@533,
R6300v1, RT-N66U@663, E1500@353, WRT54G{Lv1.1,Sv6}@250
|OpenWRT 19.7.2: RT-ACRH13, R6220, WNDR3700v4
zhelev81
DD-WRT User


Joined: 04 Feb 2014
Posts: 53

PostPosted: Wed Apr 04, 2018 14:43    Post subject: Reply with quote
ok and when you insert that module (driver) for it (xhci), in xwrt did you get the usb 3 working ? stable performance ? ... can you help me to do it on my ea6900 ? where can i download that driver for my router and how to install it?

thank you for your answer and help.
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2491
Location: Indy

PostPosted: Wed Apr 04, 2018 15:03    Post subject: Reply with quote
zhelev81 wrote:
ok and when you insert that module (driver) for it (xhci), in xwrt did you get the usb 3 working ?
Yes, all that info is here in the thread referenced by egc. Search for the driver on the router via telnet/ssh.
jwh7 wrote:
Default loaded USB 2.0 driver: 22 MB/s write, 28.5 MB/s read
insmod' USB 3.0 driver: 60 MB/s write, 110.5 MB/s read
As for stability, it read and wrote, and worked, so I'd say that's stable. Smile But again, I haven't messed with it since, because the Xwrt GUI USB Share would not work when the USB3 driver was in use, so Samba needs to be manually setup, which I haven't looked at (cuz I have a USB3 share on the A+). And nobody ever replied about whether xhci (much less the share) worked in DD.
jwh7 wrote:
Anyone try DD-WRT w/ XVortex CFE recently or try manually loading the xhci driver as I did in Xwrt? Or anyone try USB3 in recent Shibby builds?

_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
x64 OPNsense 20.1.2|FT2020.2: EA6900v1.1@1GHz, F7D8302@532|DD r42681: DIR-810L, WNDR4500v2 & 4000@533,
R6300v1, RT-N66U@663, E1500@353, WRT54G{Lv1.1,Sv6}@250
|OpenWRT 19.7.2: RT-ACRH13, R6220, WNDR3700v4
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum