WRT1900ACS v2 QoS and bufferbloat

Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
rbronco21
DD-WRT Novice


Joined: 12 Jul 2013
Posts: 12

PostPosted: Thu Nov 30, 2017 13:40    Post subject: WRT1900ACS v2 QoS and bufferbloat Reply with quote
I had QoS working and bufferbloat under control (~20ms up and down) with r30949, but decided to update. Download bufferbloat stayed in the same range, but upload jumped up to ~400ms, the same value I get if I disable QoS. After trying 7 or 8 versions, I was able to find the last working version to be r31899.

Relevant Settings (I think):
Packet Scheduler - HTB
Queueing Discipline - FQ_CODEL
Downlink (kbps) - 27500
Uplink (kbps) - 27500
All TCP-Packet Priority boxes checked
Everything below left untouched

My Frontier FIOS connection is 30/30, but I tried lowering the values with no change. I also disabled SFE on later versions that had a checkbox available. I'd love some help if there are some settings I can try, or I can help if there's any testing I can do.
Sponsor
rbronco21
DD-WRT Novice


Joined: 12 Jul 2013
Posts: 12

PostPosted: Mon Dec 11, 2017 9:15    Post subject: Reply with quote
Someone else has to be interested in good bufferbloat performance on a later version! How else am I going to play Destiny?
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2269
Location: Canada

PostPosted: Mon Dec 11, 2017 17:59    Post subject: Known issue Reply with quote
The issue is known to devs but they don't have the time or willingness to fix it.

http://svn.dd-wrt.com/ticket/5225

Similar ticket but either way, the devs refuse to work on QoS at the moment.

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.
QCA Best WiFi Settings


Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one.

Atheros:
Netgear R7800 - WDS AP, gateway, QoS
TP-Link Archer C7 v2 x2 - WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1/E3/I1 x 7 - some gateway
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - not used
UBNT loco M2 x2 - airOS

Broadcom
Linksys EA6400 - Gateway, QoS
Asus N66U - AP
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - switch
rbronco21
DD-WRT Novice


Joined: 12 Jul 2013
Posts: 12

PostPosted: Mon Dec 11, 2017 18:06    Post subject: Re: Known issue Reply with quote
ian5142 wrote:
The issue is known to devs but they don't have the time or willingness to fix it.

http://svn.dd-wrt.com/ticket/5225

Similar ticket but either way, the devs refuse to work on QoS at the moment.


Thanks, I wondered if it was known but didn't know how to find out. I wish I could go in and compare the versions I mentioned and just copy and paste the old QoS code back in. Not that simple, I know, but it'd be nice.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum