password issues with virtual interface

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
DD-WRT Novice

Joined: 21 Oct 2017
Posts: 4

PostPosted: Sun Oct 22, 2017 22:22    Post subject: password issues with virtual interface Reply with quote
I am currently using DD-WRT v24-sp2 (build 21061) on a Linksys E1200 router. I tried adding a virtual interface yesterday, so that some newly-purchased IOT devices could be separated from my main network. I followed the recommended steps to set it up, then tried to connect to the new SSID with my cell phone, in order to configure the IOT gadgets. I discovered that I could connect to the virtual interface without a problem if I had WiFi security turned off, but using WPA2 resulted in an error message stating that I had entered the wrong password. I made the DD-WRT setup page display the password, and made sure to enter it exactly. I still got the bad-password response. I can connect to the physical interface's SSID without a hitch, so the issue appears to be a DD-WRT bug, not a hardware or setting error. Is this a known problem? Is there a known work-around? I don't want to leave the secondary SSID wide open. I have security mode set to WPA2 Personal Mixed, and encryption set to TKIP+AES, at a friend's suggestion.
DD-WRT Novice

Joined: 06 Apr 2017
Posts: 21

PostPosted: Mon Oct 23, 2017 21:48    Post subject: Reply with quote
Sorry, not an answer or fix for your issue, but I've had the same experiences lately, though with absolutely current firmware (as of 10/20/17). I bought a Linksys R8000 and the physical interfaces connect with no problems. The minute I added virtual interfaces I couldn't log into some or all of the physical and most of the virtual interfaces. I found I had to disable security on most, if not all, interfaces to get connectivity. It was a constant battle to set config settings, reboot, reboot, etc. to get connectivity to the interfaces that worked just minutes before.

I'm scrapping the R8000 in favor of an R7800 (due to suggestions and reviews), but fear the problem is more related to the Broadcom chipset than the router release. I'll check in on this thread periodically as it'll probably be relevant in the next few weeks as I fight with my new R7800.


Per Yngve Berg

Joined: 13 Aug 2013
Posts: 5703
Location: Akershus, Norway

PostPosted: Mon Oct 23, 2017 22:05    Post subject: Reply with quote
Use a K3.x build.

21061 is not a very good build. Do you have the V1 or V2 of the E1200?

Use WPA2+AES only. No TKIP.
DD-WRT Novice

Joined: 21 Oct 2017
Posts: 4

PostPosted: Wed Oct 25, 2017 19:45    Post subject: password problems when trying to log into virtual VLAN Reply with quote
I have version 2. I will try the suggested setting changes.
DD-WRT Novice

Joined: 21 Oct 2017
Posts: 4

PostPosted: Thu Oct 26, 2017 0:18    Post subject: Reply with quote
After spending several days struggling with the settings, and trying multiple builds, I finally flashed Tomato firmware. It worked on my first attempt, confirming that the problem is a DD-WRT bug, not a hardware issue.

Joined: 23 Oct 2013
Posts: 2133
Location: Canada

PostPosted: Thu Oct 26, 2017 3:30    Post subject: Bug Reply with quote
It was probably a dd-wrt bug but you were running a very old build, don't blame dd-wrt if you don't update to the latest.

See my signature if you are still interested in running dd-wrt. 33525 is good, the next to builds have had numerous problems reported. See the build threads here on the forum.

Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Netgear R7800 - gateway, DHCP, QoS, VPN
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
UBNT loco M2 x2 - airOS

Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
UBNT EdgeRouter X - not used
DD-WRT Novice

Joined: 29 Jun 2019
Posts: 1

PostPosted: Sat Jun 29, 2019 16:23    Post subject: Invalid Password on virtual interface Reply with quote
I'm using a DLINK DIR-880L with firmware DD-WRT v3.0-r39715. The issue appears to still exists but isolated to the 2.4GHz interface. I have it setup as a repeater and then created a virtual interface with a different SSID. I'm using the same security alg WPA2-PSK-AES with the same shared key for both primary and virtual interfaces. The router connects correctly to my main router and gets an IP address. When I try to connect from other devices to the virtual SSID I keep getting invalid password. I tried disabling security on the virtual interface and I was able to connect successfully to it. I tried doing the same setup on the 5GHz interface and had no issues so it appears to be a bug on the 2.4GHz side only. I also tried setting up as a repeater-bridge on both 2.4GHz and 5GHz and did not have any of the invalid password issues. I've tried a few more recent firmware versions and still the same problem.
DD-WRT Novice

Joined: 15 Sep 2019
Posts: 1

PostPosted: Sun Sep 15, 2019 14:01    Post subject: Reply with quote
I am confirming the issue on my Linksys EA6900 running DD-WRT v3.0-r40672 std (08/16/19). All the observations are the same with previous authors.

I can only add that having the Virtual 2.4GHz Interface gets my router under constant load (load average 1.0 1.0 1.0)
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum