can't disable spi

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message

Joined: 12 Aug 2010
Posts: 58

PostPosted: Thu Dec 04, 2014 2:58    Post subject: can't disable spi Reply with quote
I installed on a wrt54gv6 the micro build 25527 and configured as a repeater bridge according to the instructions. Everything works OK, although I cannot disable the firewall->SPI button. I'm able to click on the "Disable" but I can't save it. I also tried with previous builds but I get the same results.

I don't know how important is that step for the functionality as a repeater, but it may be for other people.
DD-WRT Novice

Joined: 18 Jan 2015
Posts: 18

PostPosted: Sat Jan 24, 2015 17:35    Post subject: Reply with quote
This is also true for
DD-WRT v24-sp2 (01/20/15) micro - build 25974
(also on a WRT54G V6)

I can save/apply for any other settings on the page, as long as I leave SPI enabled. As soon as I disable SPI the Save and Apply buttons no longer trigger when clicked.
DD-WRT Novice

Joined: 18 Jan 2015
Posts: 18

PostPosted: Sat Jan 24, 2015 17:36    Post subject: Reply with quote
Note that I am coming from 14929 where I was able to disable SPI and save/apply just fine.
DD-WRT Novice

Joined: 19 Oct 2017
Posts: 3

PostPosted: Thu Oct 19, 2017 18:50    Post subject: Workaround? Reply with quote
I know this thread is old, but I was having the same problem and this thread topped my search results.

I think I have a workaround. I'm a total DD-WRT novice -- haven't really had to think about it much since initially installing it in 2010.

I encountered this issue when upgrading an old Linksys WRT54Gv8 from build 13637 to build 33535 (, to patch against the Krack vulnerability.

The Access Point setup instructions said to disable the SPI firewall. This worked for the old build, but not with the new build. [Clarification: I couldn't get the "disable SPI" setting to stick on build 33535. After the workaround below it does stick, and my device is now working as an access point]

Looks like there's a JavaScript issue with Firewall.asp. See for the diff between a working and non-working versions. The submitcheck function wants to check the value of log_enable, but for micro builds the log_enable control is commented out.

Here is my workaround. Your mileage may vary.

  1. Load Firewall.asp in the web browser.

  2. Open your browser's DevTools. (The following instructions are Chrome.) Go the the Elements tab and search for “log_enable”.

  3. Look for the log_enable instance in a large commented-out block below the idfilter div. Right-click on this large block and Edit as HTML. Remove the comment prefix (<!--) and suffix (-->). Click elsewhere to remove focus from the HTML tag being edited.

  4. Close DevTools.
  5. Some extra form controls will now appear. For me these controls didn't have any labels. Click on the rightmost unlabelled radio button (corresponding to log_enable in the disabled state). Then the four unlabelled drop-down controls will disappear.
  6. You might have to re-click some of the checkboxes.
  7. The "Save" button at the bottom of Firewall.asp should now work. The ARP Spoofing Protection checkbox, which I had unchecked prior to saving, got re-checked. But that didn't prevent me from following the rest of the rules at to get my device working as an AP.
  8. When the time comes to Apply Settings, do it from a page other than Firewall.asp.

By the way, for the firmware upgrade I followed the "How to update if dd-wrt is already installed" instructions at . I loaded the new firmware through the web GUI.
DD-WRT Novice

Joined: 05 Jul 2006
Posts: 9

PostPosted: Fri Feb 15, 2019 17:49    Post subject: Reply with quote
Ho god !!!! You saved my life, now, I can disable this firewall
WRT54G V5 with 2.3SP1 micro (non jtag)

Joined: 16 Nov 2015
Posts: 2492
Location: UK, London, just across the river..

PostPosted: Sat Feb 16, 2019 8:43    Post subject: Reply with quote
you must have a solid reason to disable SPI as this is not recommended at all...
only on certain cases as a WAP, client/repeater/WDS

some ppl believe disabling SPI gives a better speed...
now there is a SFE option for that on the new builds...

in general those routers affected by slow performance are very old and must be replaced instead of disabling
an important futures in order to provide better performance as they cannot provide it at all...

TP-Link WR740Nv4 --------DD-WRT 33986 BS (AP,NAT,AD Blocking,Firewall)
TP-Link WR1043NDv2 ------DD-WRT 38535 BS (AP,PPPoE,NAT,AD Blocking,AP Isolation,Firewall,Forced DNS)
TP-Link WR1043NDv2 ------DD-WRT 38581 BS (AP,NAT,AD Blocking,Firewall,Wi-Fi OFF)
TP-Link WR1043NDv2.......... Gargoyle OS 1.10 (AP,NAT,QoS,Quotas)
Netgear R7800 ------------DD-WRT 38750M 4.9 Kong (AP,NAT,AD-Blocking,AP Isolation,Firewall,DNSCrypt x2)
Netgear R7000 ---------DD-WRT 38580M Kong (AP,NAT,AD-Blocking,Firewall,Forced DNS)
Netgear ProSAFE-GS105Ev2 ----(LAN Switch)
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum