Kong's DD-WRT test build 32780M - 2017/07/21

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3, 4  Next
Author Message
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4329
Location: Netherlands

PostPosted: Fri Jul 21, 2017 11:30    Post subject: Kong's DD-WRT test build 32780M - 2017/07/21 Reply with quote
Kong's DD-WRT test build 32780M - 2017/07/21 has been released: http://desipro.de/ddwrt/K3-AC-Arm/TEST/

Changelog:
http://svn.dd-wrt.com/timeline
This build has some fixes for the SFE lockup


Your reports for Broadcom units are greatly appreciated !
Router:
Firmware:
Kernel:
Status:
Reset:
Errors:


This build thread is for reporting successes and problem with loading this experimental test build. This is important info for developers and users. Always state your hardware and SPECIFIC build (e.g. 29440_NEWD-2_K2.6_mega-nv64k.bin). Do not ask questions about your specific router or how to configure it in this thread; create your own thread to discuss any specific problems you have or need resolved. Please also do not respond to such questions. This thread is to report info, not to seek it. Posts that do not add to understanding this build will be deleted. Make sure you know how to flash properly and the risk before using this build. It is important to adhere to these requirements, to keep this thread from becoming impossibly long and useless. If you don't know what build to flash and how to flash properly and have a means of recovery if things should go wrong, do NOT flash this experimental test build.

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4329
Location: Netherlands

PostPosted: Fri Jul 21, 2017 12:00    Post subject: Reply with quote
Router Model: Netgear R6400

Firmware Version: DD-WRT v3.0-r32780M kongac (07/21/17)
Kernel Version: Linux 4.4.77 #375 SMP Fri Jul 21 12:02:04 CEST 2017 armv7l

Upgraded: from 32735M via ddup --flash-latest (thast version crashed)
Reset: Yes, Erase NVRAM

Status: Up and running for 15 min, basic setup as AP.

Errors: one GUI lockup, had to do stopservice httpd/startservice httpd via telnet.

Now running SFE tests will report back

Big Thanks to Kong and BrainSlayer!!

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
pie1394
DD-WRT Novice


Joined: 09 Apr 2014
Posts: 48

PostPosted: Fri Jul 21, 2017 13:30    Post subject: Reply with quote
The same GUI lock-up issue is observed when the SFE option is turned on via GUI although the router's SSH and WAN connections are still fine.

After the httpd service is restarted, everything is still ok after 50 min uptime. It looks like BrainSlayer indeed has found the SFE lock-up's root cause on the previous version.

_________________
Buffalo WZR-1750DHP
seanvree
DD-WRT User


Joined: 09 Sep 2015
Posts: 92

PostPosted: Fri Jul 21, 2017 13:32    Post subject: Reply with quote
Router: Netgear R7000
Firmware: Version DD-WRT v3.0-r32780M kongac (07/21/17)
Kernel: VersionLinux 4.4.77 #375 SMP Fri Jul 21 12:02:04
Status: GUI intermittent, unable to access via HTTPs
Reset: NO - Flashed via DDUP


Errors:
```


Jul 21 06:12:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:14:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:14:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:14:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:16:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:16:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:16:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:18:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:18:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:18:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:20:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:20:01 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:20:01 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:22:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:22:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:22:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:24:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:24:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:24:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:26:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:26:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:26:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:28:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:28:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:28:01 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:30:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:30:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:30:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started
Jul 21 06:32:00 VreeNetgearR7000 user.info : Maybe httpd had died, we need to re-exec it
Jul 21 06:32:00 VreeNetgearR7000 user.info : httpd : http daemon successfully stopped
Jul 21 06:32:00 VreeNetgearR7000 user.info : httpd : https daemon successfully started

```
e3000usr
DD-WRT User


Joined: 09 Jul 2014
Posts: 183

PostPosted: Fri Jul 21, 2017 14:20    Post subject: Reply with quote
Router: Asus RT-AC56U
Firmware: DD-WRT v3.0-r32780M kongac (07/21/17)
Kernel: Linux 4.4.77 #375 SMP Fri Jul 21 12:02:04 CEST 2017 armv7l
Status: OK
Reset: NO
Errors: NO

Thank you Kong and Brainslayer. Very stable builds past months. Note I do not have the sfe option enabled.
Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 180

PostPosted: Fri Jul 21, 2017 14:29    Post subject: Reply with quote
Router: Netgear R7000
Firmware: DD-WRT v3.0-r32780M kongac (07/21/17)
Kernel: Linux 4.4.77 #375 SMP Fri Jul 21 12:02:04 CEST 2017 armv7l
Status: Working
Reset: No
Previous: 32735
Errors: No

CPU Temperature : CPU 54.7 °C / WL0 45.0 °C / WL1 49.3 °C

OpenVPN 2.4.3 works
library versions: OpenSSL 1.0.2l 25 May 2017 LZO 2.09

Shortcut Forwarding Engine Disable
ARP Spoofing Protection Enable

Working very well :
Router mode : DHCP
DNSMasq
Encrypt DNS
SPI Firewall
Usb
Nas, Samba, JFFS2, miniDLNA,
wl0, wl1
Vpn

Kong and BS: Thanks for all your good work!

without VPN



with VPN


Last edited by Bernadoe on Sun Jul 23, 2017 5:35; edited 1 time in total
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4354
Location: Germany

PostPosted: Fri Jul 21, 2017 17:30    Post subject: Reply with quote
FYI, in my build qos is enabled even if sfe is turned on I have 3 x A+ on dsl reports with sfe + qos and I do not need download limit.
_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
dun4cheap
DD-WRT User


Joined: 14 Mar 2012
Posts: 243

PostPosted: Fri Jul 21, 2017 20:06    Post subject: Reply with quote
Asus AC5300

FYI,

I updated this morning to the new release. However two mornings in a row I came in and my upstream bandwidth with my IP is 20mbps, however dslreports and speettest report 300k. I have had to power off then on my router to get my upstream back. This was with SFE off and qos on. I will keep you updated with this build.

_________________
Please Fix The Following Bugs:
EOIP Settings not applied automatically after FW upgrade or reboot. http://svn.dd-wrt.com/ticket/4061

The port 80 forwarding bug with out reapplying settings appears to have been fixxed.

3 Buffalo WZR-1750DHP - DD-WRT v3.0-r29218 std (03/07/16)


6 Buffalo WZR-HP-G300NH2
DD-WRT v3.0-r29218 std (03/07/16)

all in eoip configurations, some with vlans running wep and wpa.

Some with proftp enabled and smb enabled. Mixed ISP from Timewarner cable, Cox Cable and AT&T Uverse.
r6300v2usr
DD-WRT Novice


Joined: 03 Jan 2017
Posts: 49
Location: Lindau, Germany

PostPosted: Fri Jul 21, 2017 20:24    Post subject: Re: Kong's DD-WRT test build 32780M - 2017/07/21 Reply with quote
Router: Netgear R6300v2

Firmware: DDD-WRT v3.0-r32780M kongac (07/21/17)D-WRT v3.0-r32780M kongac (07/21/17)
Kernel: Linux R6300v2 4.4.77 #375 SMP Fri Jul 21 12:02:04 CEST 2017 armv7l DD-WRT

Status: Running for 60 Minutes

Upgraded: Upgraded from 32735 via ddup --flash-latest
Reset: Not this time

Errors: None

Shortcut Forwarding Engine: 737 MBits/s, without SFE: 215 MBits/s => I keep it enabled. Let*s see what is going to happen...

Router mode : DHCP
DNSMasq with DNScrypt
SPI Firewall
USB: Harddrive and Printer
NAS: Samba, miniDLNA
WLAN: wl0, wl1 and virtual access point wl0.1
Guest Wifi: Chillispot on wl0.1 using internal lighttpd
openVPN server
SSH
pixelserv-tls (via opkg)

All running very well, this and the last builds from june are very stable in my config.
Thanks for the hard work BrainSlayer and Kong.
JAMESMTL
DD-WRT Guru


Joined: 13 Mar 2014
Posts: 856
Location: Montreal, QC

PostPosted: Fri Jul 21, 2017 21:07    Post subject: Reply with quote
R7000 SFE seems stable as I did not see any lockups over 1 hour testing

Config was default only user + pass and WAN type

WAN DHCP:
speedtest.net 750-850 (avg ~840) Download / 112 Upload (Rate Limited)
iperf3 -P 4 949
iperf3 -P 4 -R 949

WAN PPPOE
speedtest.net 650-750 Download (avg ~730) / 114 Upload (Max Line Rate)

_________________
IPv6 Ready - HE IPv6 Tunnel
http://test-ipv6.com (10/10)
http://ipv6-test.com (20/20)
http://test-ipv6.netiter.dk (20/20)

Yamaraj
DD-WRT User


Joined: 25 Jan 2017
Posts: 96

PostPosted: Fri Jul 21, 2017 21:48    Post subject: Reply with quote
Router: Netgear R8500
Firmware: DD-WRT v3.0-r32780M kongac (07/21/17)
Kernel: Linux 4.4.77 #375 SMP Fri Jul 21 12:02:04 CEST 2017 armv7l
Status: Working (with problems)
CPU Temperature: CPU 46.9 °C / WL0 51.0 °C / WL1 45.6 °C / WL2 49.3 °C
Reset: Yes/No (tried both)
Errors: Web interface hangs, SFE problems with OpenVPN - explained below.

Functions enabled: DNSMasq (hosts), USB, NAS/samba, OpenVPN client with policy based routing.

Problems: Web interfaces locks up a lot in r32735M and r32780M both. Firmware upgrade button causes lockup in Chromium; Firefox/Edge work. When SFE is enabled, VPN/PBR (OpenVPN) does not work. All the systems not specified in PBR, and hence unaffected by VPN, functional normally. On at least two occasions the router has locked up upon reboot.

SFE disabled for now.
Ah-Pin-Kor
DD-WRT User


Joined: 19 Sep 2015
Posts: 267

PostPosted: Sat Jul 22, 2017 0:12    Post subject: Reply with quote
DIR-890L

I set SFE on for testing even though I could reach my max wan 200/200 without it. No lockups on this build so far.

_________________

Netgear R7800 kongpro 19.07 20190919 || Netgear R7000 36070M kongac (Client Bridge=5GHz, AP=2.4GHz with bridged VAP)
Linksys WRT32X davidc502 OpenWrt || Linksys WRT1200ACv1 Gargoyle 1.11.x
Linksys WRT1900ACSv2 dd-wrt 39956
JAMESMTL
DD-WRT Guru


Joined: 13 Mar 2014
Posts: 856
Location: Montreal, QC

PostPosted: Sat Jul 22, 2017 0:15    Post subject: Reply with quote
Hi Kong,

Interesting observation, httpd (web gui) is now also listening on ipv6.

@Anyone As i've already reset my r7000 to AP config, cam someone using ipv6 and default firewall please post result of:

ip6tables -vnL

thanks

_________________
IPv6 Ready - HE IPv6 Tunnel
http://test-ipv6.com (10/10)
http://ipv6-test.com (20/20)
http://test-ipv6.netiter.dk (20/20)

dragonC
DD-WRT User


Joined: 23 May 2015
Posts: 213

PostPosted: Sat Jul 22, 2017 0:18    Post subject: Reply with quote
<Kong> wrote:
FYI, in my build qos is enabled even if sfe is turned on I have 3 x A+ on dsl reports with sfe + qos and I do not need download limit.


@Kong, SFE interferes/breaks vlan setup between Router (R7000) & AP (R6300v2).

Symptoms:
- Device behind VLAN3 through the trunk port on R6300v2 AP to R7000 lost internet connectivity.
- The same VLAN3 device is successfully getting assigned a VLAN3 IP address, so only the WAN (or NAT?) access is affected.

On R7000:
vlan2ports=0 5u
vlan3ports=4t 5
vlan1ports=1 2 3 4 5*

port5vlans=1 2 3 16
port3vlans=1
port1vlans=1
port4vlans=1 3 16
port2vlans=1
port0vlans=2

On R6300v2:
vlan2ports=4 5u
vlan3ports=0 3t 5
vlan1ports=1 2 3t 5*

port5vlans=1 2 3 16
port3vlans=1
port1vlans=1 3 16
port4vlans=3
port2vlans=1
port0vlans=2

Please let me know if you'd like me to open a ticket
seanvree
DD-WRT User


Joined: 09 Sep 2015
Posts: 92

PostPosted: Sat Jul 22, 2017 0:55    Post subject: Reply with quote
JAMESMTL wrote:
Hi Kong,

Interesting observation, httpd (web gui) is now also listening on ipv6.

@Anyone As i've already reset my r7000 to AP config, cam someone using ipv6 and default firewall please post result of:

ip6tables -vnL

thanks


@jamesmtl :

I'm using default firewall and IPv6:


```
BusyBox v1.27.1 (2017-07-21 12:01:01 CEST) built-in shell (ash)

root@VreeNetgearR7000:~# ip6tables -vnL
Chain INPUT (policy ACCEPT 1 packets, 72 bytes)
pkts bytes target prot opt in out source destination
0 0 ACCEPT 0 * * ::/0 ::/0 state RELATED,ESTABLISHED
10745 1582K ACCEPT icmpv6 * * ::/0 ::/0
0 0 ACCEPT 0 * * fe80::/64 ::/0
0 0 ACCEPT 0 br0 * ::/0 ::/0
28 2240 DROP 0 * * ::/0 ::/0

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
355K 209M ACCEPT 0 * * ::/0 ::/0 state RELATED,ESTABLISHED
8279 3223K ACCEPT 0 * vlan2 ::/0 ::/0
0 0 ACCEPT icmpv6 * * ::/0 ::/0 ipv6-icmp type 128 limit: avg 2/
sec burst 5
637 49230 DROP 0 * * ::/0 ::/0

Chain OUTPUT (policy ACCEPT 18205 packets, 1807K bytes)
pkts bytes target prot opt in out source destination
root@VreeNetgearR7000:~#
```
Goto page 1, 2, 3, 4  Next Display posts from previous:    Page 1 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum