Is a VPN client config possible-WNR2000v3 / v24-sp2 / 25697

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
leejenson
DD-WRT Novice


Joined: 11 Mar 2017
Posts: 36

PostPosted: Sat Mar 11, 2017 18:36    Post subject: Is a VPN client config possible-WNR2000v3 / v24-sp2 / 25697 Reply with quote
Hi,

Is it possible to configure a VPN client on the following build please?

Router Name
DD-WRT
Router Model
Netgear WNR2000v3
Firmware Version
DD-WRT v24-sp2 (12/22/14) - build 25697
Kernel Version
Linux 3.5.7.33 #17747 Mon Dec 22 04:59:53 CET 2014 mips


Also when I select Services>VPN, the page just sits there blank. Generally the firmware is working as a WIFI repeater.

Thanks

Lee


Last edited by leejenson on Sun Mar 12, 2017 11:49; edited 1 time in total
Sponsor
js1662
DD-WRT Guru


Joined: 23 Jul 2014
Posts: 1237
Location: BC, CA

PostPosted: Sat Mar 11, 2017 23:01    Post subject: Reply with quote
If the page is blank, that may mean that VPN is not available for that build. I am not sure if it is because the build is too old or what. You can try a more recent build if you like. Anyway, your router has only 4M of flash so OpenVPN is not available due to the flash limitation but I would think it may have PPTP.

Since v3 is Atheros based, I will move this thread to the correct forum for you.
leejenson
DD-WRT Novice


Joined: 11 Mar 2017
Posts: 36

PostPosted: Sun Mar 12, 2017 11:47    Post subject: I will do more research Reply with quote
js1662, thank you for your assistance and correcting the location, I will do some more research on other builds for my router.

Regards, Lee
leejenson
DD-WRT Novice


Joined: 11 Mar 2017
Posts: 36

PostPosted: Fri Mar 17, 2017 11:02    Post subject: Cause found Reply with quote
Hi,

I found the problem with the missing VPN tab, I did not install the wnr2000v3-webflash.bin file. This I have done now and also downgrade to build 18777, this was the only build that had a successful wnr2000v3-webflash.bin install. (as per your WIKI).

Regards

Lee
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4861
Location: Texas

PostPosted: Fri Mar 17, 2017 13:57    Post subject: Re: Cause found Reply with quote
leejenson wrote:
Hi,

I found the problem with the missing VPN tab, I did not install the wnr2000v3-webflash.bin file. This I have done now and also downgrade to build 18777, this was the only build that had a successful wnr2000v3-webflash.bin install. (as per your WIKI).

Regards

Lee

Just a suggestion but maybe something a bit newer than the 18777 Shocked
I just aquired a WNR2000v3 couple days a go and have been looking it over --
FWIW this is what I found:
Only a few webflash.bin that will fit on that router ... more than I listed here but this is just what I tried that were of correct size

26866 will install but BAD / telnet broken / ssh broken / Cannot obtain IP with wireless clients
27858 decent - good wireless.
39739 decent - good wireless.
29837 decent - wireless ok but seems a bit flaky?¿
29440 decent - good wireless.

Very short term wireless test with WiFi sweetspots from driod phone
'bout all I know

js1662 is correct -VPN only has option for PPTP Server or PPTP Client -- too small flash for openVPN


Last edited by mrjcd on Thu May 11, 2017 12:48; edited 1 time in total
leejenson
DD-WRT Novice


Joined: 11 Mar 2017
Posts: 36

PostPosted: Fri Mar 17, 2017 16:53    Post subject: 29940 failed Reply with quote
Hi, I went for the highest build in your list and the img was ok but the .bin failed.

I would like to check my process with yours please, I did this:-

1. 30/30/30 reset
2. Install NETGEAR version wnr2000v3-V1.0.1.26.img as per the wiki

https://secure.dd-wrt.com/wiki/index.php/Netgear_WNR2000V3

3. Install wnr2000v3-factory_WW.img
4. Install wnr2000v3-webflash.bin (failed)

Edit 17/03/2017 18:19 UK > I also paused Windows Defender.

If you have been successful with the same router as me, there must be a difference in our steps.

Thanks

Lee
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4861
Location: Texas

PostPosted: Sat Mar 18, 2017 3:22    Post subject: Re: 29940 failed Reply with quote
leejenson wrote:
Hi, I went for the highest build in your list and the img was ok but the .bin failed.

I would like to check my process with yours please, I did this:-

1. 30/30/30 reset
2. Install NETGEAR version wnr2000v3-V1.0.1.26.img as per the wiki

https://secure.dd-wrt.com/wiki/index.php/Netgear_WNR2000V3

3. Install wnr2000v3-factory_WW.img
4. Install wnr2000v3-webflash.bin (failed)

Edit 17/03/2017 18:19 UK > I also paused Windows Defender.

If you have been successful with the same router as me, there must be a difference in our steps.

Thanks

Lee

I can tell you from experience that from stock firmware you should always go with what the wiki says.
Meaning (for 1st install) if you have the netgear fw 1.0.1.26 installed you should use the '18777' wnr2000v3-factory_NA.img or the wnr2000v3-factory_WW.img depending where your router is from.
After the 18777 is installed you can go straight to 29440 wnr2000v3-webflash.bin --- that is what I did.
ftp://ftp.dd-wrt.com/betas/2016/04-11-2016-r29440/netgear-wnr2000v3/

Many factory-to-ddwrt.img files for many routers do not work. These are not all tested -- not many folks care to install stock FW after they have dd-wrt just so they can see if the new factory to dd-wrt.img works Smile
Always stay with what the wiki says for 1st flash or ask here --- also know that the wiki is not always updated with the best recommended dd-wrt build -- but it should always be accurate for 1st flash install because that would never change ... ok????

If you already have any version of dd-wrt on the wnr2000v3 the 29440 wnr2000v3-webflash.bin should install without a problem. I wouldn't be doing 30/30/30 resets with that router... completely unnecessary. Reset it once after you first install dd-wrt then do a simple reset if need to clear out old settings.
try-
unplug for 30 seconds
clear you browsers cache.
Make sure computer has a true DHCP address from router or set a static IP.
Using the GUI select correct wnr2000v3-webflash.bin
and it should work --- give it plenty of time 4 - 5 minutes ... really shouldn't take that long but anyone can wait 5 minutes

I never had any problems installing (correct) webflash.bin on this router --- tried many that would not work usually just didn't insatll and went back to previous build and then some that required a TFTP recovery ... but not any problem with 29440

EDIT:
Fairly sure that 29440 required a restart after install before could access router -- many of the builds did.
Just unplug for 20 seconds then power back on.


Last edited by mrjcd on Thu May 11, 2017 12:51; edited 1 time in total
leejenson
DD-WRT Novice


Joined: 11 Mar 2017
Posts: 36

PostPosted: Sat Mar 18, 2017 10:53    Post subject: Success Reply with quote
Hi,

All working great with build 29940.

To review the things I did wrong:-

1. I forgot to install the .bin file with 25697
2. I did not understand that the .img and .bin can be unpaired.
3. I did not understand that using a base flash (in the wiki) and then applying .bins to upgrade is the stable procedure.
4. I was using the wrong base flash for WNR2000v3 and changed 25697 to 18777 (see wiki).
5. I then upgraded using the .bin from build 29940.

All working, if I could post you a beer I would. Thanks for your patience.

Lee
Smile
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4861
Location: Texas

PostPosted: Sat Mar 18, 2017 12:20    Post subject: Re: Success Reply with quote
leejenson wrote:
Hi,

All working great with build 29940.

To review the things I did wrong:-

1. I forgot to install the .bin file with 25697
2. I did not understand that the .img and .bin can be unpaired.
3. I did not understand that using a base flash (in the wiki) and then applying .bins to upgrade is the stable procedure.
4. I was using the wrong base flash for WNR2000v3 and changed 25697 to 18777 (see wiki).
5. I then upgraded using the .bin from build 29940.

All working, if I could post you a beer I would. Thanks for your patience.

Lee
Smile


Good Job -- hope it lasts a long time for you Cool
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum