Flashing Buffalo WZR-HP-AG300H

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2
Author Message
droid-I
DD-WRT User


Joined: 10 Oct 2014
Posts: 100

PostPosted: Tue Aug 30, 2016 10:18    Post subject: Reply with quote
As for point 3) I recall i had some help by running "ping 192.168.11.1 -t" from a 2nd command window,
then I could see when the response changed to know the time for applying tftp command from the
initial command prompt window.

_________________
EA6900 v3.0-r33555 std ░ WZR-HP-AG300H-DD-WRT v3.0-r33529 std ░ WHR3-G54 v3.0-r29193 mini ░ WLI-TX4-G54HP ░ WBMR-HP-GNV2 ░ TL-MR3420v²
Sponsor
uruiamme
DD-WRT Novice


Joined: 09 Nov 2011
Posts: 25

PostPosted: Mon Jan 16, 2017 21:35    Post subject: WZR-HP-AG300H flash Reply with quote
I had somehow acquired a Buffalo WZR-HP-AG300H which had been flashed with OpenWRT and set to the 192.168.15.1 IP address. The way I found out that it was OpenWRT was that the authentication page popped up when I tried to go to the web configuration... The authentication window said Openwrt.lan or something.

I did not have the password, so that's as far as I could go.

Well, I don't know much about OpenWRT, but I did find out that it is a bear to wipe out. They do NOT have a way to simply wipe the configuration settings. (You can't just hit the reset button on the bottom for 30 seconds or whatever) To load defaults, you go into a special recovery mode with telnet (in the case of this router, it is by pushing the USB Eject button while it boots). But since the firmware was evidently borked, any attempts to mount_root or reset the root password FAILED using telnet and it just gave me errors each time.

So I decided to combine the OpenWRT instructions on using TFTP to flash a new firmware (a supported way to do upgrades or fresh install) with the DD-WRT instruction to flash a new firmware (a supported way to do a fresh install from Buffalo firmware).

I just picked out an acceptable DD-WRT version to load it with. Specifically, I wanted a relatively new one with the latest USA enhancements to the high power 5 GHz range from the FCC.

But even this was a mess.

The instructions to use a hardwired switch did not work for the TFTP process. I had done this before on other routers, but in this case the TFTP client never connected. I couldn't even get a single ping reply on 192.168.11.1.

As a last resort, I connected directly to the laptop with a LAN cable. My Windows 10 seems to take forever to configure LAN networking as it tries to figure out the network topology when you do it this way. But it somehow worked... about 10 seconds after booting the WZR-HP-AG300H, one of my TFTP attempts worked. I still saw no ping replies.

So everyone... follow the instructions in this thread... be aware that the switch may hinder you, Windows definitely will. There was a slight improvement needed to make the Windows 10 instruction work:

Open a cmd prompt with administrator permissions.

Code:
netsh interface ip delete neighbors "Local Area Connection" "192.168.11.1"

netsh interface ip add neighbors "Local Area Connection" 192.168.11.1 02-AA-BB-CC-DD-20


The "Local Area Connection" name comes from the Windows page at Control Panel\All Control Panel Items\Network Connections (which most of you are familiar with). My desktop calls it "Ethernet 2" and other computers will vary. You have to change that part or it won't work.

As for the exact version to flash with... you must follow the instructions on the Router wiki page. My page is at https://www.dd-wrt.com/wiki/index.php/Buffalo_WZR-HP-AG300H and it specifies the ones which say "buffalo_to_ddwrt_webflash-MULTI.bin" in the filename. I got the one for r29721 at ftp://ftp.dd-wrt.com/betas/2016/05-18-2016-r29721/buffalo_wzr-hp-ag300h/

I used TFTPUtil Client GUI for Windows.

One more tidbit: my red light never entered a "flashing" state like the DD-WRT and OpenWRT instructions said. I had to guess when the red light was supposed to be flashing, since mine stayed red.

The first time I ever saw a red flashing LED was when I was doing the TFTP process... first slow, then fast.

In case this gets asked again:
YES, YOU CAN PUT DD-WRT ON A ROUTER THAT USED TO HAVE OPENWRT ON IT. I did it with a TFTP client.
tdiguy
DD-WRT User


Joined: 20 Apr 2010
Posts: 192

PostPosted: Sat Jan 28, 2017 19:12    Post subject: Reply with quote
I have the hp-g300nh myself.
It has been years since i was able to flash firmware on this via web utility. I have had dd-wrt on it since i have owned it.
Personally i am a windows guy so i use pumpkin for tftp. Its a really small program, very user friendly and i can easily jack the timeout period up.
I also highly recommend using hub or switch to anyone with a windows setup. The time it takes windows to turn the port back on makes it very difficult to nail the timing.
uruiamme
DD-WRT Novice


Joined: 09 Nov 2011
Posts: 25

PostPosted: Fri Apr 21, 2017 7:22    Post subject: Reply with quote
tdiguy wrote:
I have the hp-g300nh myself.
I also highly recommend using hub or switch to anyone with a windows setup. The time it takes windows to turn the port back on makes it very difficult to nail the timing.


I am sorry to say that you are wrong, but you are wrong here. I will reiterate this. You are wrong.

The above lengthy description of my OpenWRT to dd-wrt flash said specifically that my frustrated efforts only paid off when I connected directly to the router without a switch in the middle.

I know that there are other flash "how to"s that recommend a switch in the middle, and I have followed them myself, and I understand why this usually helps.

But that simply did not work for me. I would never have guessed it, and I certainly didn't get a ping reply to tell me things were going right. But for whoever has a similar issue with an TFTP flash, try a direct connection, even as a last resort, and go with what works. For all I know, I am the only one in the world to have needed this unusual method of flashing, but that was my experience.
Brian95
DD-WRT Novice


Joined: 07 Oct 2017
Posts: 1

PostPosted: Sat Oct 07, 2017 23:23    Post subject: Buffalo WZR-HP-G300NH bricked on upgrading to latest beta Reply with quote
This method can also be used if your initial firmware upgrade failed by some reason and the only light you can see on the router is the DIAG led that flashes constantly or intermittenly.by the way i was upgrading from dd-wrt's old ver to newer latest one.
to flash i used windows's built in TFTP

– The Buffalo WZR-HP-G300NH can only be flashed when the router has its factory default IP address, that is : 192.168.11.1
- This can be simply made by pressing the reset button on the bottom of the router for more than 3 seconds.
– You will need to know the MAC address of the router. You can find that on the web interface of the router or on the router itself on the white sticker.( in my case when connected via win 10 (64bit),Router IP was showing some random# and router’s Mac Address was weird random #.in my case since router’s web interface showing weird random# so I noted down from the sticker on the router it was called serial # but breaking down to two letter group. For ex. 4C-E6-76-3F-20-7C
Now , you can either do this from the Windows 7 or windows 10 (64bit only) or Linux. in my case Did not work with win 7(32bit)
Windows 10 (64bit)
As your router is dead , your machine will not have valid IP address assigned so you will need to assign it manually. Change IPV4 address as buffalo’s Default IP is 192.168.11.1 so
1) Network Connections window will appear. Right click correct Local Area Connection by identifying correct network card and click Properties.

2)Select Internet Protocol (TCP/IP) (IPV4), Leave IPV6 alone. Click on Properties.
You can now manually type in the IP address, Subnet mask, Default gateway and DNS servers.
Assign the following IP address: 192.168.11.2 and Subnet Mask: 255.255.255.0 Default gate way 192.168.11.1 DNS Server can be same as Router’s ip (192.168.11.1) or leave it blank. I left it blank.

3) Turn Windows firewall off or any third party firewall for that matter.
4)power off the router and leave it connected to your machine by the network cable plugged into one of the 4 black Ethernet ports (LAN Port).

5) Open a command prompt and type “route print” in order to get a list of your network card adapters. Write down the number of your network card.
My list looks something like:
Network Adapter
12…00 1b fc 6b 3f d8 ……Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
11…00 1b fc 6b 36 d4 ……Realtek PCI GBE Family Controller
26…00 50 56 c0 00 01 ……VMware Virtual Ethernet Adapter for VMnet1
27…00 50 56 c0 00 08 ……VMware Virtual Ethernet Adapter for VMnet8
1………………………Software Loopback Interface 1
6) My active network card it is number 12
Now you will need to bind the interface number 12 with the routers MAC address and you can do this by going back to the command prompt: to make sure there is not any existing binding so we needs to delete that first if there any?. So first delete existing binding and rebind with new ip.
netsh interface ip delete neighbors "Local Area Connection" "192.168.11.1"
“or”
netsh interface ipv4 delete neighbors 12 192.168.11.1 4C-E6-76-3F-20-7C
netsh interface ipv4 add neighbors 12 192.168.11.1 4C-E6-76-3F-20-7C
Where 4C-E6-76-3F-20-7C is the actual MAC address of your OWN router and replace the number 12 with your own interface number.
*****Some have used dummy mac address as following but I used it as indicated above.******
netsh interface ip delete neighbors "Local Area Connection" "192.168.11.1"

netsh interface ip add neighbors "Local Area Connection" 192.168.11.1 02-AA-BB-CC-DD-20
7) Open Windows command prompt and cd into directory where you copied the original firmware. In my case, I had it c:\Users\Brian\Desktop\.
cd \Users\Brian\Desktop\ ..Locate the firmware file on your computer that you want load on router or have it flashed. I kept it on desktop, buffalo to_ddwrt_webflash-MULTI.bin (smallfile). c:\Users\Bharat\Desktop\ . so in cmd prompt type or copy and paste cd \Users\Brian\Desktop\ . cd \ to go to c dir. Then cd \Users\Bharat\Desktop\
**** Reason for above instructions::, to use Microsoft provided windows built in tftp utility it only can be used from the same directory where bin file or firmware file is located. So in this case I had bin file(firmware) on desktop..

Cool turn tftp utility on from “turn windows features on or off”..by default it’s off. You can do this in earlier steps prior to changing ipv4 address as well!.

9) in cmd box,set command as following cd \Users\Brian\Desktop\
c:\Users\Brian\Desktop\ put tftp command so command line will look like below.
c:\Users\Brian\Desktop\tftp -i 192.168.11.1 put wzr-hp-g300nh-dd-wrt-webupgrade-MULTI.bin

DO NOT HIT ENTER AFTER TYPING THIS HOWEVER! Just keep it ready to hit enter.

10).Plug the power cable into the router and wait 1-2 seconds before you hit enter for the TFTP command you just entered above. The TFTP command will let you know if the transfer was successful. If router takes some time to connect or ip address takes while thus small time window available to put bin file goes away then use network switch between computer and router. Computer>Lan switch>router Lan. That way computer does not looses ip address during rebooting of router. in my case I did not use any switch.

11). After 5-10 minutes, unplug and replug the router. I would wait 10 minutes or more to err on the side of caution. Or until diag lights stops flashing.
12). Remove the previously added static arp entry. Remember to replace 12 with the interface number of the NIC you are using based on the route print results.

netsh interface ipv4 delete neighbors 12 192.168.11.1 4C-E6-76-3F-20-7C
“or” if you have used dummy mac address
netsh interface ipv4 delete neighbors 12 192.168.11.1 02-AA-BB-CC-DD-1A

13). Change IPV4 setting to obtain ip address and dns address automatically. Configure Windows PC NIC connected to router to use DHCP settings and disable then re-enable the NIC. You should get a network address from the 192.168.1.1xx network.

14). You should now be able to log into the WebGUI http://192.168.1.1.
15) After successfully logging into the router, I downloaded latest firmware from dd-wrt’s beta website (ftp://ftp.dd-wrt.com/betas/ )WZR-HP-G300NH web upgrade firmware.
16). Using the WebGUI, I was able to successfully update the firmware to the latest version. Hope this helps someone newbie like me!.
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum