L2TP or IKEv2 VPN Server Possible? Apple is removing PPTP

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4  Next
Author Message
wesli
DD-WRT Novice


Joined: 01 Jul 2012
Posts: 27

PostPosted: Thu Nov 10, 2016 9:17    Post subject: Reply with quote
I got a PN from Kong.
There is a change made by BS and this requires a fix in Kong's build. Will be available in the next build.
Sponsor
DaveTheNerd
DD-WRT User


Joined: 15 Jul 2008
Posts: 317

PostPosted: Thu Nov 10, 2016 20:17    Post subject: Reply with quote
wesli wrote:
I got a PN from Kong.
There is a change made by BS and this requires a fix in Kong's build. Will be available in the next build.


Looks like 30870M is up on Kong's repo.
Starbuck99
DD-WRT Novice


Joined: 26 May 2012
Posts: 10

PostPosted: Wed Nov 16, 2016 8:05    Post subject: Reply with quote
Has anyone been able to get the VPN working with latest kong built?

Running Firmware: DD-WRT v3.0-r30880M kongac (11/14/16)
On Linksys EA6900 V1.1
nolimitz
DD-WRT Guru


Joined: 26 Nov 2010
Posts: 577

PostPosted: Wed Nov 16, 2016 12:39    Post subject: Reply with quote
@Kong

i've updated R6300V2 (AP only) to 30880 yesterday using ddup,

i've enabled softEther server and applied settings.

initially i can connect locally to router ip:5555 using softether vpn server manager on Windows 7.

i went through the setup (password setting, VPN type, IPSec, DDNS, user, pre shared key, etc) then opened the port in my gateway (R6300V2 is only AP) i've put the settings in my iphone iOS 10, error message "vpn server not responding"

i then clicked edit config and pasted config on dd-wrt gui, applied settings, no change, server not responding.

then i deleted the config from ddwrt gui and applied settings, then reboot the router,

i can no longer connect to router using SoftEther vpn server manager using windows, i get "access has been denied" although the password is saved (and also kept on a notepad).

appreciate some help,

thanks Kong
wesli
DD-WRT Novice


Joined: 01 Jul 2012
Posts: 27

PostPosted: Wed Nov 16, 2016 22:57    Post subject: Reply with quote
I can also connect to the router using the vpn server manager. I can configure the softether server, but I can not connect to it. I get following error when I try connect from my MAC:

"A connection could not be established to the PPP server. Try reconnecting. If the problem continues, verify your settings and contact your Administrator."

When I enter a wrong password I'm getting an "Authentication failed" error.
Bloodboy
DD-WRT Novice


Joined: 28 Jul 2011
Posts: 13

PostPosted: Thu Nov 17, 2016 18:45    Post subject: Reply with quote
Yesterday i have tested as much as i could but had no real success...

The problem is the config.
I think the server does not load it properly.

And your both problems reconnecting with the manager is no real problem. The password is just empty!
Try it and you will see that you can reconnect to the server and all your config is gone Sad

Edit:

And i think the port bindings are wrong too...

root@DDWRT:~# netstat -ltu
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:5555 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:domain 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:ssh 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:https 0.0.0.0:* LISTEN
netstat: /proc/net/tcp6: No such file or directory
udp 0 0 localhost:4500 0.0.0.0:*
udp 0 0 DDWRT.home:4500 0.0.0.0:*
udp 0 0 DDWRT:4500 0.0.0.0:*
udp 0 0 169.254.255.1:4500 0.0.0.0:*
udp 0 0 0.0.0.0:47082 0.0.0.0:*
udp 0 0 localhost:500 0.0.0.0:*
udp 0 0 DDWRT.home:500 0.0.0.0:*
udp 0 0 DDWRT:500 0.0.0.0:*
udp 0 0 169.254.255.1:500 0.0.0.0:*
udp 0 0 0.0.0.0:50996 0.0.0.0:*
udp 0 0 0.0.0.0:domain 0.0.0.0:*
udp 0 0 0.0.0.0:bootps 0.0.0.0:*
udp 0 0 0.0.0.0:34643 0.0.0.0:*
ponylee
DD-WRT Novice


Joined: 28 Nov 2016
Posts: 2

PostPosted: Mon Nov 28, 2016 9:27    Post subject: Sorry can someone help.. Reply with quote
May i use any solution on tp link 841 nd V8

use l2tp server for ios 10 phone ? Sad

have any solution .....
scram69
DD-WRT Novice


Joined: 05 Dec 2016
Posts: 2

PostPosted: Mon Dec 05, 2016 1:31    Post subject: Latest build 30910M? Reply with quote
Has anyone tried getting Softether working on the latest build (30910M)?
nolimitz
DD-WRT Guru


Joined: 26 Nov 2010
Posts: 577

PostPosted: Mon Dec 05, 2016 3:20    Post subject: Re: Latest build 30910M? Reply with quote
scram69 wrote:
Has anyone tried getting Softether working on the latest build (30910M)?


yes i tried, did not work for me.

@Kong, after copying config from softether manager, and pasting it into dd-wrt gui config box, then saving it, each spaces are replaced by &#, see attached screenshot, can it be causing a problem?



vpn-save.png
 Description:
 Filesize:  107.77 KB
 Viewed:  13886 Time(s)

vpn-save.png


scram69
DD-WRT Novice


Joined: 05 Dec 2016
Posts: 2

PostPosted: Mon Dec 05, 2016 4:27    Post subject: Reply with quote
I'm pretty sure the # in the config file is the comment delimiter; anything on the line after the # will be ignored by openVPN. So you will need to edit out the & and # characters.
madmathtw
DD-WRT Novice


Joined: 05 Dec 2016
Posts: 1

PostPosted: Mon Dec 05, 2016 8:47    Post subject: Reply with quote
SoftEther VPN of this version(Kong's DD-WRT build 30910M) could be configured by Softether tool.
the config setting in WebUI is not apply after reboot.
After reboot, all settings of Softether will be default value.

I could use "vpncmd localhost:443 /SERVER /PASSWORD: /CMD ConfigSet //tmp//vpn_server.config" command in firewall script to apply the settings.
But I still cannot use Windows and Android phone to establish vpn connection. Still trying.....
allyourfase
DD-WRT Novice


Joined: 07 Dec 2016
Posts: 2

PostPosted: Wed Dec 07, 2016 13:29    Post subject: Same problems Reply with quote
I am having the same problems as everyone else I think. When I configure softether vpn server on my windows machine and then copy the config file over, all the leading spaces get replaced with & # 9 ; & # 9 ; (but without the spaces) and I think this is what's preventing it from working. When I paste the config text in, the & # 9 ; isn't there so it is something about saving and applying the settings that's causing the change.

Has anyone gotten softether to work yet with an iPhone L2TP VPN setup? Maybe I'm also doing the softether server setup wrong? Does anyone have a walk-through on that?

Thanks!
wesli
DD-WRT Novice


Joined: 01 Jul 2012
Posts: 27

PostPosted: Wed Dec 07, 2016 14:36    Post subject: Reply with quote
@allyourfase

Only TAB's are replaced with
I copied my config file in a text editor and replaced all TAB's with 4 blanks.
Then I copy & pasted my config in the DD-WRT L2TP settings.
The file is correctly saved. But still can't connect to my R7000 router.
So the problem is not in the config file.

Im getting following error message when I try to connect from my Macbook:

"The L2TP-VPN server did not respond. Try reconnecting. If the problem continues, verify your settings and contact your Administrator."
slidermike
DD-WRT Guru


Joined: 11 Nov 2013
Posts: 1487
Location: USA

PostPosted: Wed Dec 07, 2016 15:10    Post subject: Reply with quote
Kong,
any iperf tests you can post results on with IPSEC compared to other forms of vpn encryption?
Its interesting to see which is more cpu intensive (potential bottleneck).
<Kong> wrote:
Softether which supports IPSEC is in the works, first test looks ok, just needs a bit of polishing in the webif.

_________________
Router currently owned:
Netgear R7800 - Router
Netgear R7000 - AP mode

R7000 specific Tips/Tricks.
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=264152
allyourfase
DD-WRT Novice


Joined: 07 Dec 2016
Posts: 2

PostPosted: Wed Dec 07, 2016 15:14    Post subject: Reply with quote
@wesli

Ah, good to know about the tabs.

I get the same error with my iPhone also and I am running an R7000 with DD-WRT v3.0-r30910M kongac (12/02/16).

How did you setup the softether server to get the config file to begin with?

I still haven't seen or heard of anyone getting this working yet, have you?
Goto page Previous  1, 2, 3, 4  Next Display posts from previous:    Page 3 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum