New DD-WRT build 30016

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3, 4, 5  Next
Author Message
KrypteX
DD-WRT Guru


Joined: 18 Jan 2014
Posts: 2411

PostPosted: Mon Jun 27, 2016 9:05    Post subject: Reply with quote
add210 wrote:
Router : TP-Link TL-WR940N V3
Version: 06-24-2016-r30016/tplink_tl-wr941ndv6/
Errors: WAN & LAN ports not working

It's a known issue: http://www.dd-wrt.com/phpBB2/viewtopic.php?p=1033565#1033565

_________________
THERE ARE NO STRANGERS HERE; ONLY FRIENDS YOU HAVEN'T YET MET.
________________________________________________________________________________________________________
DD-WRT CHANGELOG | DEVICES | DD-WRT BUILDS | KONG BUILDS | UNOFFICIAL BUILDS | DD-WRT in VIRTUALBOX

Testing BrainSlayer's DD-WRT build 31924 on various units:
NETGEAR : WNDR3800 WNDR3800CH WNDRMACv2 WNDRMACv1 WNR2200 WNR2000v3
TP-LINK : ArcherC7v3 WR1043NDv3 WR740Nv4 WR740Nv6 WR710Nv1 WR810Nv1 WA850REv1 WA901NDv3 WA901NDv4
D-LINK : DIR-862L DIR-615D2
ASUS : RT-N10 C1
VirtualBox : x86_64
Sponsor
demoralized
DD-WRT User


Joined: 13 Apr 2013
Posts: 61

PostPosted: Mon Jun 27, 2016 11:54    Post subject: Reply with quote
Yo kryptex.

Any news when will you have some precious free time to update the changelog?

Best regards.
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3959
Location: UK, London, just across the river..

PostPosted: Mon Jun 27, 2016 11:56    Post subject: Reply with quote
demoralized wrote:
Yo kryptex.

Any news when will you have some precious free time to update the changelog?

Best regards.


+1

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 44538 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 44715 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 44772 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 44849 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 44849 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
cybero2912
DD-WRT Guru


Joined: 18 Jun 2006
Posts: 1190
Location: Berlin

PostPosted: Mon Jun 27, 2016 14:39    Post subject: Reply with quote
broken webif on AR2317 devices (tested on DIR-300 and Fonera)

Router Model: DIR-300 /Fonera
Firmware Version DD-WRT v3.0-r30016 std (06/24/16)
Reset: YES
Errors: Webinterface not working
Status: NOT OK

output on console when trying to open webif:
Code:

cannot load /lib/do_pagehead_vis
cannot load /lib/nvg_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/wl_packet_get_visual.so
cannot load /lib/dumpmeminfo_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/active_wireless_visual.so
cannot load /lib/active_wds_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/dumpleases_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/showad_visual.so
cannot load /lib/show_control_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/insertpageToken_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/show_wl_mac_visual.so
cannot load /lib/show_wl_mac_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/nvram_status_get_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/show_wifiselect_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/get_radio_state_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/getwirelessmode_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/getwirelessnetmode_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/getwirelessssid_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/get_curchannel_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/get_txpower_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/get_currate_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/get_service_state_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvim_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvim_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/nvm_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/statnv_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/statfs_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/statfs_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/statfs_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/gps_status_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/getlongitude_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/getlatidude_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvg_visual.so
cannot load /lib/getgpslink_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/getwirelessstatus_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/ifndef_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/nvem_visual.so
cannot load /lib/nvem_visual.so
cannot load /lib/show_paypal_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/get_firmware_version_visual.so
cannot load /lib/tran_visual.so
cannot load /lib/get_uptime_visual.so
cannot load /lib/show_wanipinfo_visual.so

back to v3.0-r29974 = all OK
Frakko
DD-WRT User


Joined: 06 May 2016
Posts: 389

PostPosted: Tue Jun 28, 2016 6:15    Post subject: Reply with quote
[quote="Knomax"]Router Model & version: TPLINK WR1043ND V3 DD-WRT v3.0-r30016 (06/24/16)
Reset: X2
Errors: 0
Status:OK

Still have bad bufferbloat at upstream...nothing change even if i choose HTB,HFSC..SFQ..FQ_CODEL!!![/quote]

How to install this firmware on 1043 v3?
Do you show me the link and guide?
jwoods
DD-WRT User


Joined: 13 Mar 2016
Posts: 403

PostPosted: Tue Jun 28, 2016 6:24    Post subject: Reply with quote
Frakko wrote:
Still have bad bufferbloat at upstream...nothing change even if i choose HTB,HFSC..SFQ..FQ_CODEL!!!



Start with 95% of your total allowed maximum uplink/downlink speeds, and work down from there.

Use WAN, HTB, and FQ_CODEL to start.

Check the boxes for ACK, SYN, FIN, and RST.

Disable any other priorites.

Test at www.dslreports.com/speedtest

Get a good baseline, backup your config, add in any priorities you had previously one at a time, re-test.
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7382
Location: YWG, Canada

PostPosted: Tue Jun 28, 2016 6:28    Post subject: Reply with quote
jwoods wrote:
Frakko wrote:
Still have bad bufferbloat at upstream...nothing change even if i choose HTB,HFSC..SFQ..FQ_CODEL!!!



Start with 95% of your total allowed maximum uplink/downlink speeds, and work down from there.

Use WAN, HTB, and FQ_CODEL to start.

Check the boxes for ACK, SYN, FIN, and RST.

Disable any other priorites.

Test at www.dslreports.com/speedtest

Get a good baseline, backup your config, add in any priorities you had previously one at a time, re-test.


there is still a problem with qos in our ddwrt, http://svn.dd-wrt.com/ticket/5225 but under certain conditions as ive found in that ticket

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r44863 std
[QUALCOMM] DIR-862L --------------------------------> r44863 std
[QUALCOMM] WNDR4300 v1 --------------------------> r44863 std
[QUALCOMM] DIR-862L --------------------------------> r44863 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------------------------> r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
jwoods
DD-WRT User


Joined: 13 Mar 2016
Posts: 403

PostPosted: Tue Jun 28, 2016 6:37    Post subject: Reply with quote
tatsuya46 wrote:
there is still a problem with qos in our ddwrt, http://svn.dd-wrt.com/ticket/5225 but under certain conditions as ive found in that ticket


I fit that profile and get an "A" for bufferbloat on DSLReports.com.

I posted QOS config and test results in another thread over the weekend.

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=1037023&highlight=#1037023
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7382
Location: YWG, Canada

PostPosted: Tue Jun 28, 2016 6:53    Post subject: Reply with quote
jwoods wrote:
tatsuya46 wrote:
there is still a problem with qos in our ddwrt, http://svn.dd-wrt.com/ticket/5225 but under certain conditions as ive found in that ticket


I fit that profile and get an "A" for bufferbloat on DSLReports.com.

I posted QOS config and test results in another thread over the weekend.

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=1037023&highlight=#1037023


what is ur provider's provided uplink speed? do u have any services entered for services priority? (yes i did see ur link)

i too, get an "A", but if using global settings, & no uplink settings below 1Mbps.

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r44863 std
[QUALCOMM] DIR-862L --------------------------------> r44863 std
[QUALCOMM] WNDR4300 v1 --------------------------> r44863 std
[QUALCOMM] DIR-862L --------------------------------> r44863 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------------------------> r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
jwoods
DD-WRT User


Joined: 13 Mar 2016
Posts: 403

PostPosted: Tue Jun 28, 2016 6:58    Post subject: Reply with quote
tatsuya46 wrote:
what is ur provider's provided uplink speed? do u have any services entered for services priority?


6 down and 1 up.

No priorities enabled except TCP-Packets.
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7382
Location: YWG, Canada

PostPosted: Tue Jun 28, 2016 7:01    Post subject: Reply with quote
jwoods wrote:
tatsuya46 wrote:
what is ur provider's provided uplink speed? do u have any services entered for services priority?


6 down and 1 up.

No priorities enabled except TCP-Packets.


cable or (v)dsl? would u be willing to set a custom rate of something much lower like 4096 kbps down, & 256 kbps up (maintain NO services priorities entered, tcp-packets are okay). then do a speedtest, while uploading, & do a pingtest to a nearby server such as google, youtube, etc. u should have heavy packet loss &/or latency while on the uplink test, but not on the download test. this is with all, codel, fq_codel, sfq, & all combos with htb/hfsc.

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r44863 std
[QUALCOMM] DIR-862L --------------------------------> r44863 std
[QUALCOMM] WNDR4300 v1 --------------------------> r44863 std
[QUALCOMM] DIR-862L --------------------------------> r44863 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------------------------> r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
jwoods
DD-WRT User


Joined: 13 Mar 2016
Posts: 403

PostPosted: Tue Jun 28, 2016 7:08    Post subject: Reply with quote
tatsuya46 wrote:
cable or (v)dsl? would u be willing to set a custom rate of something much lower like 4096 kbps down, & 256 kbps up (maintain NO services priorities entered, tcp-packets are okay). then do a speedtest, while uploading, & do a pingtest to a nearby server such as google, youtube, etc. u should have heavy packet loss &/or latency while on the uplink test, but not on the download test. this is with all, codel, fq_codel, sfq, & all combos with htb/hfsc.


DSL.

When I get some free time in life I can run a WinMRT and show both latency and packet loss.

I noticed that retransmit averages dropped considerably when I started using TCP-Packets (from the 4 to 5% range to 3%).
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7382
Location: YWG, Canada

PostPosted: Tue Jun 28, 2016 7:24    Post subject: Reply with quote
jwoods wrote:
tatsuya46 wrote:
cable or (v)dsl? would u be willing to set a custom rate of something much lower like 4096 kbps down, & 256 kbps up (maintain NO services priorities entered, tcp-packets are okay). then do a speedtest, while uploading, & do a pingtest to a nearby server such as google, youtube, etc. u should have heavy packet loss &/or latency while on the uplink test, but not on the download test. this is with all, codel, fq_codel, sfq, & all combos with htb/hfsc.


DSL.

When I get some free time in life I can run a WinMRT and show both latency and packet loss.

I noticed that retransmit averages dropped considerably when I started using TCP-Packets (from the 4 to 5% range to 3%).


Thanks, if u can, could u please show ur result from both speedtest.net & dslreports's speedtest (using cmd (or linux/mac eq if u use) constant ping to a nearby stable server)?

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r44863 std
[QUALCOMM] DIR-862L --------------------------------> r44863 std
[QUALCOMM] WNDR4300 v1 --------------------------> r44863 std
[QUALCOMM] DIR-862L --------------------------------> r44863 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------------------------> r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
powerking88
DD-WRT Novice


Joined: 18 May 2016
Posts: 3

PostPosted: Tue Jun 28, 2016 7:29    Post subject: Reply with quote
Router Model: TP-Link TL-WR841ND V11
Firmware Version: DD-WRT v3.0-r30016 std (06/24/16)
Kernel Version: Linux 3.18.35 #13640 Fri Jun 24 02:47:33
CEST 2016 mips
Reset: No
Errors: Hotspotsystem function is not working properly
Status: OK
jwoods
DD-WRT User


Joined: 13 Mar 2016
Posts: 403

PostPosted: Tue Jun 28, 2016 7:33    Post subject: Reply with quote
Two tests.

One without ping on upload...one with.
Goto page Previous  1, 2, 3, 4, 5  Next Display posts from previous:    Page 2 of 5
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum