Can't login in my router after upgrade to DD-WRT

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
J.one
DD-WRT Novice


Joined: 01 Jan 2016
Posts: 3

PostPosted: Sat Jan 02, 2016 13:12    Post subject: Can't login in my router after upgrade to DD-WRT Reply with quote
I just upgraded from TomatoUSB to DD-WRT. First I could login fine, but after I reseted my router again (a few times), and then tried to downgrade to TomatoUSB again, I cant login anymore!

I tried all passwords and usernames I remember, but none of them work.

Even a 30/30/30 reset doens't seem to reset my pass Shocked

I have a Lynksys e4200 rev.1 .

Can anybody tip me about HOW I can reset it again to the default pass?

I'm out of idea's..

Thanks in Advance!!!

Edit:

Meanwhile I allready tried:

blanc
root

admin
root

root
admin

admin
blanc

root
blanc

and all combinations with my last predefined pass on Tomato as well as DD-WRT, no success..
Sponsor
Blakhart
DD-WRT Novice


Joined: 15 Dec 2007
Posts: 33

PostPosted: Sat Jan 02, 2016 18:16    Post subject: Reply with quote
Ok just read you went from tomato to ddwrt. A 30/30/30 reset should get you to the screen where ddwrt is asking you to enter a new user name and password. If it's not at the ddwrt new user/pw screen you might still be on tomato. In that case you will want to use passwords for tomato to get into the router.

For recovering any ddwrt pw from a tomato install see here;
"If you're upgrading from the DD-WRT firmware, telnet into the router *before* upgrading and type "nvram get http_passwd". The result will be your password in Tomato. This is necessary because of a change in DD-WRT's way of using the standard http_passwd variable.

If you have a Buffalo router or a Linksys with a pushable Cisco logo, push the AOSS/Cisco button for at least 20 seconds, then telnet into the router on port 233. Type "nvram get http_passwd" to retrieve the password or "nvram set http_passwd='your_new_password'" followed by "nvram commit" to set it manually. Reboot the router using the command "reboot" after using this method.

If nothing else works, push the reset button for a few seconds to reset all of the settings. The default password after resetting is "admin"."
http://www.polarcloud.com/tomatofaq
J.one
DD-WRT Novice


Joined: 01 Jan 2016
Posts: 3

PostPosted: Mon Jan 04, 2016 17:46    Post subject: Reply with quote
This is my DD-WRT login screen when I browse to IP of my router.

http://i64.tinypic.com/vziziu.png

I can't telnet into the router because I don't have the password, I tried!

I did a 30/30/30 reset several times. But for some reason it won't reset the password and it did't reset my SSID either!

When I "upgraded" from Tomato to DD-WRT I reset the NVRAM several times to be on the safe side, but honestly, when I "Downgraded" From DD-WRT to Tomato I didn't clear the NVRAM (because I didn't know I had to do it there as well.)


According to your explanation and my experiance I still have DD-WRT.
What I have to do is telnet into my router type "nvram get http_passwd". But I can't do that because I don't have the password, so I'm screwed?
Or can I reflash everything via the USB port including the password?
Blakhart
DD-WRT Novice


Joined: 15 Dec 2007
Posts: 33

PostPosted: Tue Jan 05, 2016 17:13    Post subject: Reply with quote
Hmmm. If you're on ddwrt it should respond to the usual 30/30/30 with a blank password and user name field for you to fill in. If it's still asking for a pw, try the ones for tomato, wich by default are the user name left empty and the pw is root, or the other way around. If worse comes to worse, you might try reflashing it after rebooting the router. What router is it?

Also see here;
"Recovering with TFTP

Note that if you already have DD-WRT installed and working, and you are on this page because you want to revert to the router firmware, you need to break DD-WRT first! THIS IS AN EXTREMELY DANGEROUS PROCESS. SEE THE FIRST LINE IN CAPS ABOVE FOR BETTER SAFER METHODS.

telnet into the router, execute:

mtd erase linux (This bricked my Buffalo WHR-HP-GN! Don't do mtd erase linux!)
reboot

(Note: only tested on the WNDR3300 with 24preSP2; YMMV)

During startup, the router will pause to accept a temporary firmware upload via tftp. On the Linksys WRT54G routers, you need to flash an image that contains the "W54G" header (Linksys and mini_wrt54g images)

If pinging 192.168.1.1 does not work, check the IP Address of your computer and make sure it is assigned an IP address in the subnet of the router IP. For simplicity sake you can assume "192.168.1.x" is good. If you do not have a good IP, the DHCP Server might not be working. So set your IP manually to something like 192.168.1.77 with 192.168.1.1 as your gateway and then try pinging the router again. Finally, you may want to use a network scanner to scan your network (smaller networks) just to be sure that your router was not assigned another IP.

Power the router on with a continuous ping running in a command window:

ping -t -w 2 192.168.1.1

The -w 2 parameter forces a lower timeout for the ping answer, this makes easier to get an answer from the bricked router.

You should see at least a few replies from 192.168.1.1. Do this several times to be sure. If it does you have good chance of simple recovery. If you still receive no response, the IP address may be something other than 192.168.1.1. You should attempt to obtain the IP address of the router. Especially if previous firmware set the boot_wait variable to on, the router pauses even longer than normal during bootup to accept a recovery flash. All you need to do is provide a firmware to it via TFTP during this window of time.

Prepare your PC, firmware file and TFTP software and play with the timing of powering it on and starting the TFTP session just after applying power (or as soon as you start to see ping replies). If you try it a number of times (at least 10) you will probably rescue the router with no fuss!

If you see an 'Invalid Password' prompt from the router the bootloader did not accept the TFTP image and the firmware is refusing the TFTP upload. You can force the bootloader to accept the TFTP upload by holding the reset button while powering up the router. You may also improve success rates by ensuring there is a switch or hub between the PC and the router, maintaining link state when the router power cycles. "
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 12675

PostPosted: Tue Jan 05, 2016 21:47    Post subject: Reply with quote
Flashing directly from one third party firmware to another without going back to oem firmware in between can cause problems such as this. I believe it has to do with how the password nvram variables are stored differently. Try going back to stock firmware.
_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
J.one
DD-WRT Novice


Joined: 01 Jan 2016
Posts: 3

PostPosted: Wed Jan 06, 2016 20:18    Post subject: Reply with quote
Its working again!!! Very Happy

Blakhart,

Thanks you so much for your help! I really appriciate it.

As it turned out, I was doing two things wrong.

1) I did the 30/30/30 reset while releasing the reset button each 30 seconds instead of holding it.

2) I didn't disconnect all network cables while doing so.

After trying MANY times with all different possibilities I figered out that was the problem.

As it turned out I was accually back on Tomato! But as you can see from the screenshot, It said login to "DD-WRT", AND it kept the SSID from DD-WRT after the "Downgrade", can u believe it?

Threre where some ohter things as well. Like DHCP that was disabled by default Confused

And before I did the 30/30/30 reset (succesfully) I wasn't able to mount my nas anymore...

I'm really glad its solved. I will stick with my good old Tomato for now I think Smile
It works, except for the slow Wifi and not stable 5GHZ.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum